diff mbox series

[36/48] python3-pytest: upgrade 8.0.0 -> 8.0.2

Message ID 1709105575-24259-36-git-send-email-wangmy@fujitsu.com
State Accepted, archived
Commit 0a6824bc920bebfa019641f8134cb287c8564bef
Headers show
Series [01/48] bash-completion: upgrade 2.11 -> 2.12.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Feb. 28, 2024, 7:32 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
============
-Fix collection on Windows where initial paths contain the short version
 of a path (for example c:\PROGRA~1\tests).
-Fix an IndexError crash raising from getstatementrange_ast.
-Reverted a fix to --maxfail handling in pytest 8.0.0 because it caused a
 regression in pytest-xdist whereby session fixture teardowns may get executed
 multiple times when the max-fails is reached.
-Correctly handle errors from getpass.getuser() in Python 3.13.
-Fix an edge case where ExceptionInfo._stringify_exception could crash
 pytest.raises().
-Fix regression with pytest.warns() using custom warning subclasses which
 have more than one parameter in their __init__.
-Fix a regression in pytest 8.0.0 whereby calling pytest.skip() and similar
 control-flow exceptions within a pytest.warns() block would get suppressed
 instead of propagating.
-Fix a regression in pytest 8.0.0 whereby autouse fixtures defined in a module
 get ignored by the doctests in the module.
-Fix a regression in pytest 8.0.0 whereby items would be collected in reverse
 order in some circumstances.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../python/{python3-pytest_8.0.0.bb => python3-pytest_8.0.2.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta/recipes-devtools/python/{python3-pytest_8.0.0.bb => python3-pytest_8.0.2.bb} (92%)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-pytest_8.0.0.bb b/meta/recipes-devtools/python/python3-pytest_8.0.2.bb
similarity index 92%
rename from meta/recipes-devtools/python/python3-pytest_8.0.0.bb
rename to meta/recipes-devtools/python/python3-pytest_8.0.2.bb
index f43796710a..57e979e909 100644
--- a/meta/recipes-devtools/python/python3-pytest_8.0.0.bb
+++ b/meta/recipes-devtools/python/python3-pytest_8.0.2.bb
@@ -5,7 +5,7 @@  DESCRIPTION = "The pytest framework makes it easy to write small tests, yet scal
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=bd27e41b6550fe0fc45356d1d81ee37c"
 
-SRC_URI[sha256sum] = "249b1b0864530ba251b7438274c4d251c58d868edaaec8762893ad4a0d71c36c"
+SRC_URI[sha256sum] = "d4051d623a2e0b7e51960ba963193b09ce6daeb9759a451844a21e4ddedfc1bd"
 
 DEPENDS += "python3-setuptools-scm-native"