diff mbox series

[28/48] pciutils: upgrade 3.10.0 -> 3.11.1

Message ID 1709105575-24259-28-git-send-email-wangmy@fujitsu.com
State Accepted, archived
Commit bbda388857284612190b58abe8d73c93e39d1574
Headers show
Series [01/48] bash-completion: upgrade 2.11 -> 2.12.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Feb. 28, 2024, 7:32 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

configure.patch
refreshed for 3.11.1

Changelog:
===========
* Fixed wrong API version in lib/pci.h.
* Updated README.Windows.
* Fix compilation on Windows.
* update-pciids now supports XZ compression. If libpci is configured
  with support for compression, all downloaded files are recompressed
  as gzip. Otherwise they are stored as plain text.
* update-pciids now sends itself as the User-Agent.
* Added a pcilmr utility for PCIe lane margining.
* Re-factored access to i386 ports on all relevant platforms.
* Added i386 port access on OpenBSD.
* Back-ends for Windows received many bug fixes and improvements.
* ECAM back-end now scans ACPI and BIOS memory faster.
* Linux systems without pread/pwrite are no longer supported
  as they are hopefully long gone. This helps avoid the tricky check
  for presence of pread which was found to fail on musl libc.
* Improved decoding of PCIe control and status registers.
* Decoding of CXL capabilities now supports up to CXL 3.0.
* lspci now displays interrupt message numbers consistently across
  different capabilities.
* Cache of IDs resolved via DNS, which was located in ~/.pci-ids
  by default, is now stored according to the XDG base directory
  specification in $XDG_CACHE_HOME/pci-ids.
* All source files now have SPDX license identifiers.
* Internal: The "aux" fields of structs pci_access and pci_dev
  reserved for use by back-ends were renamed to backend_data to better
  reflect their meaning.
* As usually, various minor bug fixes and updated pci.ids.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 meta/recipes-bsp/pciutils/pciutils/configure.patch    | 11 +++++------
 .../{pciutils_3.10.0.bb => pciutils_3.11.1.bb}        |  2 +-
 2 files changed, 6 insertions(+), 7 deletions(-)
 rename meta/recipes-bsp/pciutils/{pciutils_3.10.0.bb => pciutils_3.11.1.bb} (95%)
diff mbox series

Patch

diff --git a/meta/recipes-bsp/pciutils/pciutils/configure.patch b/meta/recipes-bsp/pciutils/pciutils/configure.patch
index 91bd255899..5015cf4884 100644
--- a/meta/recipes-bsp/pciutils/pciutils/configure.patch
+++ b/meta/recipes-bsp/pciutils/pciutils/configure.patch
@@ -1,4 +1,4 @@ 
-From 42e7d5f5f1d84a56b125aa05de33d31e28ad1124 Mon Sep 17 00:00:00 2001
+From 561216c8cbc280aaa9aecf30cb11835a4a0a78ed Mon Sep 17 00:00:00 2001
 From: Richard Purdie <rpurdie@linux.intel.com>
 Date: Wed, 31 Dec 2008 17:20:38 +0000
 Subject: [PATCH] pciutils: Upgarde 2.2.4 -> 3.0.3
@@ -17,18 +17,17 @@  Ionut Radu <ionutx.radu@intel.com>
 2017/6/15 - RP - Cleanups and merging patches
 
 Upstream-Status: Inappropriate [embedded specific]
-
 ---
  Makefile      |  2 +-
  lib/configure | 14 ++++++++++----
  2 files changed, 11 insertions(+), 5 deletions(-)
 
 diff --git a/Makefile b/Makefile
-index 3df076d..9b247d3 100644
+index aaec04e..9c1dab0 100644
 --- a/Makefile
 +++ b/Makefile
-@@ -110,7 +110,7 @@ example$(EXEEXT): example.o lib/$(PCIIMPLIB)
- example.o: example.c $(PCIINC)
+@@ -123,7 +123,7 @@ pcilmr$(EXEEXT): pcilmr.o $(LMROBJS) $(COMMON) lib/$(PCIIMPLIB)
+ pcilmr.o: pcilmr.c $(LMRINC)
  
  %$(EXEEXT): %.o
 -	$(CC) $(LDFLAGS) $(TARGET_ARCH) $^ $(LDLIBS) -o $@
@@ -37,7 +36,7 @@  index 3df076d..9b247d3 100644
  ifdef PCI_OS_WINDOWS
  comma := ,
 diff --git a/lib/configure b/lib/configure
-index 57b064b..b269332 100755
+index 3df057a..c87e71c 100755
 --- a/lib/configure
 +++ b/lib/configure
 @@ -9,6 +9,10 @@ echo_n() {
diff --git a/meta/recipes-bsp/pciutils/pciutils_3.10.0.bb b/meta/recipes-bsp/pciutils/pciutils_3.11.1.bb
similarity index 95%
rename from meta/recipes-bsp/pciutils/pciutils_3.10.0.bb
rename to meta/recipes-bsp/pciutils/pciutils_3.11.1.bb
index e27cfd4ced..044074ccc3 100644
--- a/meta/recipes-bsp/pciutils/pciutils_3.10.0.bb
+++ b/meta/recipes-bsp/pciutils/pciutils_3.11.1.bb
@@ -14,7 +14,7 @@  DEPENDS = "zlib kmod make-native"
 SRC_URI = "${KERNELORG_MIRROR}/software/utils/pciutils/pciutils-${PV}.tar.xz \
            file://configure.patch"
 
-SRC_URI[sha256sum] = "238a2e27166730e53a17fe07bfad229e07fa39b618117e5944b6d7eda9fbb0e9"
+SRC_URI[sha256sum] = "3f472ad864473de5ba17f765cc96ef5f33e1b730918d3adda6f945a2a9290df4"
 
 inherit multilib_header pkgconfig update-alternatives