diff mbox series

[34/48] python3-pip: upgrade 23.3.2 -> 24.0

Message ID 1709105575-24259-34-git-send-email-wangmy@fujitsu.com
State Accepted, archived
Commit 73040d2ed2a440d7497b448b8e81ee19bef5858b
Headers show
Series [01/48] bash-completion: upgrade 2.11 -> 2.12.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Feb. 28, 2024, 7:32 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

no_shebang_mangling.patch
refreshed for 24.0

Changelog:
===========
-Retry on HTTP status code 502
-Automatically use the setuptools PEP 517 build backend when --config-settings
 is used for projects without pyproject.toml.
-Make pip freeze and pip uninstall of legacy editable installs of packages
 whose name contains _ compatible with setuptools>=69.0.3.
-Support per requirement --config-settings for editable installs.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../python/python3-pip/no_shebang_mangling.patch         | 9 ++++-----
 .../{python3-pip_23.3.2.bb => python3-pip_24.0.bb}       | 2 +-
 2 files changed, 5 insertions(+), 6 deletions(-)
 rename meta/recipes-devtools/python/{python3-pip_23.3.2.bb => python3-pip_24.0.bb} (97%)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-pip/no_shebang_mangling.patch b/meta/recipes-devtools/python/python3-pip/no_shebang_mangling.patch
index b59f4888da..99fa14ee03 100644
--- a/meta/recipes-devtools/python/python3-pip/no_shebang_mangling.patch
+++ b/meta/recipes-devtools/python/python3-pip/no_shebang_mangling.patch
@@ -1,4 +1,4 @@ 
-From 915bf32cd117cd86cc0d4b96bc9490b1c7119ffd Mon Sep 17 00:00:00 2001
+From 2aa82aeb0783c5fa7777b32bfe1dd3da9ae8fc6e Mon Sep 17 00:00:00 2001
 From: Richard Purdie <richard.purdie@linuxfoundation.org>
 Date: Wed, 23 Feb 2022 12:27:06 +0000
 Subject: [PATCH] python3-pip: Don't change shebang
@@ -8,16 +8,15 @@  to be python3 from the environment when building anything for the target
 (or nativesdk). This avoids incorrect interpreter paths in the target scripts.
 
 Upstream-Status: Inappropriate [OE specific config]
-
 ---
  src/pip/_vendor/distlib/scripts.py | 4 +++-
  1 file changed, 3 insertions(+), 1 deletion(-)
 
 diff --git a/src/pip/_vendor/distlib/scripts.py b/src/pip/_vendor/distlib/scripts.py
-index d270624..42c0d10 100644
+index cfa45d2..313f499 100644
 --- a/src/pip/_vendor/distlib/scripts.py
 +++ b/src/pip/_vendor/distlib/scripts.py
-@@ -137,6 +137,8 @@ class ScriptMaker(object):
+@@ -144,6 +144,8 @@ class ScriptMaker(object):
          See also: http://www.in-ulm.de/~mascheck/various/shebang/#length
                    https://hg.mozilla.org/mozilla-central/file/tip/mach
          """
@@ -26,7 +25,7 @@  index d270624..42c0d10 100644
          if os.name != 'posix':
              simple_shebang = True
          else:
-@@ -348,7 +350,7 @@ class ScriptMaker(object):
+@@ -362,7 +364,7 @@ class ScriptMaker(object):
                  return
  
              match = FIRST_LINE_RE.match(first_line.replace(b'\r\n', b'\n'))
diff --git a/meta/recipes-devtools/python/python3-pip_23.3.2.bb b/meta/recipes-devtools/python/python3-pip_24.0.bb
similarity index 97%
rename from meta/recipes-devtools/python/python3-pip_23.3.2.bb
rename to meta/recipes-devtools/python/python3-pip_24.0.bb
index 0f2ab9288b..be4a29500a 100644
--- a/meta/recipes-devtools/python/python3-pip_23.3.2.bb
+++ b/meta/recipes-devtools/python/python3-pip_24.0.bb
@@ -33,7 +33,7 @@  inherit pypi python_setuptools_build_meta
 
 SRC_URI += "file://no_shebang_mangling.patch"
 
-SRC_URI[sha256sum] = "7fd9972f96db22c8077a1ee2691b172c8089b17a5652a44494a9ecb0d78f9149"
+SRC_URI[sha256sum] = "ea9bd1a847e8c5774a5777bb398c19e80bcd4e2aa16a4b301b718fe6f593aba2"
 
 do_install:append() {
     rm -f ${D}/${bindir}/pip