diff mbox series

[14/48] libpcre2: upgrade 10.42 -> 10.43

Message ID 1709105575-24259-14-git-send-email-wangmy@fujitsu.com
State Accepted, archived
Commit 6a0cb6e129d5602808f34fd2a9460fc05d9520d6
Headers show
Series [01/48] bash-completion: upgrade 2.11 -> 2.12.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Feb. 28, 2024, 7:32 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

License-Update: Copyright year updated to 2024.

Changelog:
============
* The JIT code no longer supports ARMv5 architecture.
* A new function pcre2_get_match_data_heapframes_size() for finer heap control.
* New option flags to restrict the interaction between ASCII and non-ASCII
  characters for caseless matching and \d and friends. There are also new
  pattern constructs to control these flags from within a pattern.
* Upgrade to Unicode 15.0.0.
* Treat a NULL pattern with zero length as an empty string.
* Added support for limited-length variable-length lookbehind assertions, with
  a default maximum length of 255 characters (same as Perl) but with a function
  to adjust the limit.
* Support for LoongArch in JIT.
* Perl changed the meaning of (for example) {,3} which did not used to be
  recognized as a quantifier. Now it means {0,3} and PCRE2 has also changed.
  Note that {,} is still not a quantifier.
* Following Perl, allow spaces and tabs after { and before } in all Perl-
  compatible items that use braces, and also around commas in quantifiers. The
  one exception in PCRE2 is \u{...}, which is from ECMAScript, not Perl, and
  PCRE2 follows ECMAScript usage.
* Changed the meaning of \w and its synonyms and derivatives (\b and \B) in UCP
  mode to follow Perl. It now matches characters whose general categories are L
  or N or whose particular categories are Mn (non-spacing mark) or Pc
  (combining punctuation).
* Changed the default meaning of [:xdigit:] in UCP mode to follow Perl. It now
  matches the "fullwidth" versions of hex digits. PCRE2_EXTRA_ASCII_DIGIT can
  be used to keep it ASCII only.
* Make PCRE2_UCP the default in UTF mode in pcre2grep and add -no_ucp,
  --case-restrict and --posix-digit.
* Add --group-separator and --no-group-separator to pcre2grep.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../libpcre/{libpcre2_10.42.bb => libpcre2_10.43.bb}          | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
 rename meta/recipes-support/libpcre/{libpcre2_10.42.bb => libpcre2_10.43.bb} (92%)

Comments

Richard Purdie Feb. 28, 2024, 7:33 p.m. UTC | #1
On Wed, 2024-02-28 at 15:32 +0800, wangmy via lists.openembedded.org wrote:
> From: Wang Mingyu <wangmy@fujitsu.com>
> 
> License-Update: Copyright year updated to 2024.
> 
> Changelog:
> ============
> * The JIT code no longer supports ARMv5 architecture.
> * A new function pcre2_get_match_data_heapframes_size() for finer heap control.
> * New option flags to restrict the interaction between ASCII and non-ASCII
>   characters for caseless matching and \d and friends. There are also new
>   pattern constructs to control these flags from within a pattern.
> * Upgrade to Unicode 15.0.0.
> * Treat a NULL pattern with zero length as an empty string.
> * Added support for limited-length variable-length lookbehind assertions, with
>   a default maximum length of 255 characters (same as Perl) but with a function
>   to adjust the limit.
> * Support for LoongArch in JIT.
> * Perl changed the meaning of (for example) {,3} which did not used to be
>   recognized as a quantifier. Now it means {0,3} and PCRE2 has also changed.
>   Note that {,} is still not a quantifier.
> * Following Perl, allow spaces and tabs after { and before } in all Perl-
>   compatible items that use braces, and also around commas in quantifiers. The
>   one exception in PCRE2 is \u{...}, which is from ECMAScript, not Perl, and
>   PCRE2 follows ECMAScript usage.
> * Changed the meaning of \w and its synonyms and derivatives (\b and \B) in UCP
>   mode to follow Perl. It now matches characters whose general categories are L
>   or N or whose particular categories are Mn (non-spacing mark) or Pc
>   (combining punctuation).
> * Changed the default meaning of [:xdigit:] in UCP mode to follow Perl. It now
>   matches the "fullwidth" versions of hex digits. PCRE2_EXTRA_ASCII_DIGIT can
>   be used to keep it ASCII only.
> * Make PCRE2_UCP the default in UTF mode in pcre2grep and add -no_ucp,
>   --case-restrict and --posix-digit.
> * Add --group-separator and --no-group-separator to pcre2grep.
> 
> Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
> ---
>  .../libpcre/{libpcre2_10.42.bb => libpcre2_10.43.bb}          | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>  rename meta/recipes-support/libpcre/{libpcre2_10.42.bb => libpcre2_10.43.bb} (92%)

This breaks glib-2.0 ptests:

https://autobuilder.yoctoproject.org/typhoon/#/builders/81/builds/6325/
https://autobuilder.yoctoproject.org/typhoon/#/builders/82/builds/6136

Cheers,

Richard
diff mbox series

Patch

diff --git a/meta/recipes-support/libpcre/libpcre2_10.42.bb b/meta/recipes-support/libpcre/libpcre2_10.43.bb
similarity index 92%
rename from meta/recipes-support/libpcre/libpcre2_10.42.bb
rename to meta/recipes-support/libpcre/libpcre2_10.43.bb
index f471b3f90a..fd0bd79212 100644
--- a/meta/recipes-support/libpcre/libpcre2_10.42.bb
+++ b/meta/recipes-support/libpcre/libpcre2_10.43.bb
@@ -8,14 +8,14 @@  SUMMARY = "Perl Compatible Regular Expressions version 2"
 HOMEPAGE = "http://www.pcre.org"
 SECTION = "devel"
 LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENCE;md5=41bfb977e4933c506588724ce69bf5d2"
+LIC_FILES_CHKSUM = "file://LICENCE;md5=321a5eb46acae6b6c1ff2c7a866d836a"
 
 SRC_URI = "${GITHUB_BASE_URI}/download/pcre2-${PV}/pcre2-${PV}.tar.bz2"
 
 GITHUB_BASE_URI = "https://github.com/PhilipHazel/pcre2/releases"
 UPSTREAM_CHECK_REGEX = "releases/tag/pcre2-(?P<pver>\d+(\.\d+)+)$"
 
-SRC_URI[sha256sum] = "8d36cd8cb6ea2a4c2bb358ff6411b0c788633a2a45dabbf1aeb4b701d1b5e840"
+SRC_URI[sha256sum] = "e2a53984ff0b07dfdb5ae4486bbb9b21cca8e7df2434096cc9bf1b728c350bcb"
 
 CVE_PRODUCT = "pcre2"