diff mbox series

[meta-python,7/9] python3-execnet: upgrade 1.9.0 -> 2.0.2

Message ID 20230721192530.2515633-7-tgamblin@baylibre.com
State Under Review
Headers show
Series [meta-python,1/9] python3-awesomeversion: upgrade 22.9.0 -> 23.5.0 | expand

Commit Message

Trevor Gamblin July 21, 2023, 7:25 p.m. UTC
execnet requires hatchling and hatch-vcs now, instead of setuptools.

Changelog (https://github.com/pytest-dev/execnet/blob/master/CHANGELOG.rst):

2.0.2 (2023-07-09)

- Re-release without code changes, just to include tox.ini into the source distribution.

2.0.1 (2023-07-08)

- Re-release without code changes, just to include docs and tests into the source distribution.

2.0.0 (2023-07-06)

- Removed support for Python < 3.7.
  - Applied pyupgrade --py37-plus.
  - Minimal mypy fixes and dropped Python 2 support code.
- Migrated packaging to hatch.
- Dropped deprecated APIs of old makegateway names.
- Removed py testing dependency.
- Explicitly pass encoding when opening files in the gateway to get rid of warnings when using PYTHONWARNDEFAULTENCODING=1 (#195).
- Fixed error when loading source code files from a path containing non-ascii characters.

Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
---
 .../{python3-execnet_1.9.0.bb => python3-execnet_2.0.2.bb}  | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-execnet_1.9.0.bb => python3-execnet_2.0.2.bb} (82%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-execnet_1.9.0.bb b/meta-python/recipes-devtools/python/python3-execnet_2.0.2.bb
similarity index 82%
rename from meta-python/recipes-devtools/python/python3-execnet_1.9.0.bb
rename to meta-python/recipes-devtools/python/python3-execnet_2.0.2.bb
index ea17e84143..a934d1c461 100644
--- a/meta-python/recipes-devtools/python/python3-execnet_1.9.0.bb
+++ b/meta-python/recipes-devtools/python/python3-execnet_2.0.2.bb
@@ -8,14 +8,14 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=772fcdaca14b378878d05c7d857e6c3e"
 
 DEPENDS += "\
     python3-pip-native \
-    python3-setuptools-scm-native \
+    python3-hatch-vcs-native \
 "
 
 SRC_URI += "file://run-ptest \
            "
-SRC_URI[sha256sum] = "8f694f3ba9cc92cab508b152dcfe322153975c29bda272e2fd7f3f00f36e47c5"
+SRC_URI[sha256sum] = "cc59bc4423742fd71ad227122eb0dd44db51efb3dc4095b45ac9a08c770096af"
 
-inherit ptest pypi setuptools3
+inherit ptest pypi python_hatchling
 
 do_install_ptest() {
     install -d ${D}${PTEST_PATH}/tests