diff mbox series

[meta-python,1/9] python3-awesomeversion: upgrade 22.9.0 -> 23.5.0

Message ID 20230721192530.2515633-1-tgamblin@baylibre.com
State Under Review
Headers show
Series [meta-python,1/9] python3-awesomeversion: upgrade 22.9.0 -> 23.5.0 | expand

Commit Message

Trevor Gamblin July 21, 2023, 7:25 p.m. UTC
The project has stopped using setuptools in favor of poetry, so inherit
python_poetry_core instead.

Changelog (https://github.com/ludeeus/awesomeversion/releases/tag/23.5.0):

- Add CI for Python 3.11 by @ludeeus in #191
- Add demo page by @ludeeus in #195
- Add better styles to demo by @ludeeus in #197
- Remove setuptools from dev-dependencies by @ludeeus in #202
- Update demo with compare by @ludeeus in #219
- Add Python 3.12 to CI by @ludeeus in #222
- Add in_range helper method by @ludeeus in #224
- Restructure README contents by @ludeeus in #225

Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
---
 ...someversion_22.9.0.bb => python3-awesomeversion_23.5.0.bb} | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-awesomeversion_22.9.0.bb => python3-awesomeversion_23.5.0.bb} (76%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-awesomeversion_22.9.0.bb b/meta-python/recipes-devtools/python/python3-awesomeversion_23.5.0.bb
similarity index 76%
rename from meta-python/recipes-devtools/python/python3-awesomeversion_22.9.0.bb
rename to meta-python/recipes-devtools/python/python3-awesomeversion_23.5.0.bb
index 20ed1890db..bcd959cb27 100644
--- a/meta-python/recipes-devtools/python/python3-awesomeversion_22.9.0.bb
+++ b/meta-python/recipes-devtools/python/python3-awesomeversion_23.5.0.bb
@@ -4,8 +4,8 @@  SECTION = "devel/python"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENCE.md;md5=92622b5a8e216099be741d78328bae5d"
 
-SRC_URI[sha256sum] = "2f4190d333e81e10b2a4e156150ddb3596f5f11da67e9d51ba39057aa7a17f7e"
+SRC_URI[sha256sum] = "a505558316010d2d10d487226f79c1157204af00fa462fdcf948e347011dd491"
 
 RDEPENDS:${PN} += "python3-profile python3-logging"
 
-inherit pypi setuptools3
+inherit pypi python_poetry_core