diff mbox series

[meta-python,6/9] python3-blinker: add python3-asyncio to RDEPENDS

Message ID 20230721192530.2515633-6-tgamblin@baylibre.com
State Under Review
Headers show
Series [meta-python,1/9] python3-awesomeversion: upgrade 22.9.0 -> 23.5.0 | expand

Commit Message

Trevor Gamblin July 21, 2023, 7:25 p.m. UTC
The module fails to import without this.

Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
---
 meta-python/recipes-devtools/python/python3-blinker_1.6.2.bb | 4 ++++
 1 file changed, 4 insertions(+)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-blinker_1.6.2.bb b/meta-python/recipes-devtools/python/python3-blinker_1.6.2.bb
index 8e77df088d..b0728e66cd 100644
--- a/meta-python/recipes-devtools/python/python3-blinker_1.6.2.bb
+++ b/meta-python/recipes-devtools/python/python3-blinker_1.6.2.bb
@@ -8,6 +8,10 @@  inherit pypi python_setuptools_build_meta ptest
 
 SRC_URI += "file://run-ptest"
 
+RDEPENDS:${PN} += "\
+        ${PYTHON_PN}-asyncio \
+"
+
 RDEPENDS:${PN}-ptest += " \
 	${PYTHON_PN}-pytest \
 "