diff mbox series

[meta-python,089/149] python3-lockfile: add missing run-time dependencies

Message ID 20230531082437.10646-90-brgl@bgdev.pl
State New
Headers show
Series python3: improve run-time dependencies situation | expand

Commit Message

Bartosz Golaszewski May 31, 2023, 8:23 a.m. UTC
From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>

Add missing RDEPENDS for this package.

Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
---
 .../recipes-devtools/python/python3-lockfile_0.12.2.bb       | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-lockfile_0.12.2.bb b/meta-python/recipes-devtools/python/python3-lockfile_0.12.2.bb
index b9dc4722a..af738e08e 100644
--- a/meta-python/recipes-devtools/python/python3-lockfile_0.12.2.bb
+++ b/meta-python/recipes-devtools/python/python3-lockfile_0.12.2.bb
@@ -12,6 +12,9 @@  SRC_URI[sha256sum] = "6aed02de03cba24efabcd600b30540140634fc06cfa603822d508d5361
 inherit pypi setuptools3
 
 DEPENDS += "python3-distutils-extra-native python3-pbr-native"
-RDEPENDS:${PN} += "python3-sqlite3"
+RDEPENDS:${PN} += " \
+    python3-io \
+    python3-sqlite3 \
+"
 
 BBCLASSEXTEND = "native nativesdk"