diff mbox series

[meta-python,040/149] python3-tornado: add missing run-time dependencies

Message ID 20230531082437.10646-41-brgl@bgdev.pl
State New
Headers show
Series python3: improve run-time dependencies situation | expand

Commit Message

Bartosz Golaszewski May 31, 2023, 8:22 a.m. UTC
From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>

Add missing RDEPENDS for this package.

Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
---
 meta-python/recipes-devtools/python/python3-tornado_6.3.bb | 4 ++++
 1 file changed, 4 insertions(+)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-tornado_6.3.bb b/meta-python/recipes-devtools/python/python3-tornado_6.3.bb
index 2d9606bb8..af5009b6a 100644
--- a/meta-python/recipes-devtools/python/python3-tornado_6.3.bb
+++ b/meta-python/recipes-devtools/python/python3-tornado_6.3.bb
@@ -12,6 +12,7 @@  inherit pypi setuptools3
 
 # Requires _compression which is currently located in misc
 RDEPENDS:${PN} += " \
+    python3-asyncio \
     python3-certifi \
     python3-compression \
     python3-ctypes \
@@ -19,9 +20,12 @@  RDEPENDS:${PN} += " \
     python3-html \
     python3-json \
     python3-misc \
+    python3-multiprocessing \
     python3-numbers \
     python3-pkgutil \
+    python3-pycurl \
     python3-threading \
+    python3-unittest \
 "
 
 RDEPENDS:${PN}-test += "python3-unittest"