diff mbox series

[meta-python,028/149] python3-sqlalchemy: don't use PYTHON_PN and improve coding style

Message ID 20230531082437.10646-29-brgl@bgdev.pl
State New
Headers show
Series python3: improve run-time dependencies situation | expand

Commit Message

Bartosz Golaszewski May 31, 2023, 8:22 a.m. UTC
From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>

We no longer support python2. Drop PYTHON_PN and use python3 explicitly.
While at it: make indentation consistent.

Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
---
 .../python/python3-sqlalchemy_2.0.15.bb          | 16 ++++++++--------
 1 file changed, 8 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.15.bb b/meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.15.bb
index 3af41bed2..b30437830 100644
--- a/meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.15.bb
+++ b/meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.15.bb
@@ -10,14 +10,14 @@  PYPI_PACKAGE = "SQLAlchemy"
 inherit pypi setuptools3
 
 RDEPENDS:${PN} += " \
-    ${PYTHON_PN}-json \
-    ${PYTHON_PN}-pickle \
-    ${PYTHON_PN}-logging \
-    ${PYTHON_PN}-netclient \
-    ${PYTHON_PN}-numbers \
-    ${PYTHON_PN}-threading \
-    ${PYTHON_PN}-compression \
-    ${PYTHON_PN}-profile \
+    python3-compression \
+    python3-json \
+    python3-logging \
+    python3-netclient \
+    python3-numbers \
+    python3-pickle \
+    python3-profile \
+    python3-threading \
 "
 
 BBCLASSEXTEND = "native nativesdk"