diff mbox series

[meta-python,039/149] python3-tornado: remove the testing submodule from FILES:${PN}-test

Message ID 20230531082437.10646-40-brgl@bgdev.pl
State New
Headers show
Series python3: improve run-time dependencies situation | expand

Commit Message

Bartosz Golaszewski May 31, 2023, 8:22 a.m. UTC
From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>

Tornado has the testing submodule in __all__ so calling:

  from tornado import *

fails if we don't include the ptest package. To fix it: put the testing
module into the main package.

Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
---
 meta-python/recipes-devtools/python/python3-tornado_6.3.bb | 1 -
 1 file changed, 1 deletion(-)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-tornado_6.3.bb b/meta-python/recipes-devtools/python/python3-tornado_6.3.bb
index bceb50956..2d9606bb8 100644
--- a/meta-python/recipes-devtools/python/python3-tornado_6.3.bb
+++ b/meta-python/recipes-devtools/python/python3-tornado_6.3.bb
@@ -32,5 +32,4 @@  PACKAGES =+ "\
 
 FILES:${PN}-test = " \
     ${libdir}/${PYTHON_DIR}/site-packages/*/test \
-    ${libdir}/${PYTHON_DIR}/site-packages/*/testing.py* \
 "