diff mbox series

[08/20] python3-hypothesis: fix run-time dependencies

Message ID 20230517080639.9336-9-brgl@bgdev.pl
State Accepted, archived
Commit 434f9473791f0159bf79df7731753ff91bdbe190
Headers show
Series python3: fix run-time dependencies | expand

Commit Message

Bartosz Golaszewski May 17, 2023, 8:06 a.m. UTC
From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>

The main hypothesis module depends on pytest already so move it to
global RDEPENDS from ptest-specific ones.

Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
---
 meta/recipes-devtools/python/python3-hypothesis_6.71.0.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-hypothesis_6.71.0.bb b/meta/recipes-devtools/python/python3-hypothesis_6.71.0.bb
index 8ec885fabf..15f4090c6d 100644
--- a/meta/recipes-devtools/python/python3-hypothesis_6.71.0.bb
+++ b/meta/recipes-devtools/python/python3-hypothesis_6.71.0.bb
@@ -20,13 +20,13 @@  RDEPENDS:${PN} += " \
     python3-compression \
     python3-core \
     python3-json \
+    python3-pytest \
     python3-sortedcontainers \
     python3-statistics \
     python3-unittest \
     "
 
 RDEPENDS:${PN}-ptest += " \
-    ${PYTHON_PN}-pytest \
     ${PYTHON_PN}-unittest-automake-output \
     "