diff mbox series

[03/20] python3-attrs: don't use PYTHON_PN

Message ID 20230517080639.9336-4-brgl@bgdev.pl
State Accepted, archived
Commit 877e55cd5d626c2ad06624992ff9e17a2b481acf
Headers show
Series python3: fix run-time dependencies | expand

Commit Message

Bartosz Golaszewski May 17, 2023, 8:06 a.m. UTC
From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>

We no longer support python2. Drop PYTHON_PN and use python3 explicitly.

Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
---
 meta/recipes-devtools/python/python3-attrs_23.1.0.bb | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-attrs_23.1.0.bb b/meta/recipes-devtools/python/python3-attrs_23.1.0.bb
index 207636d62e..ab3a08073d 100644
--- a/meta/recipes-devtools/python/python3-attrs_23.1.0.bb
+++ b/meta/recipes-devtools/python/python3-attrs_23.1.0.bb
@@ -8,13 +8,13 @@  SRC_URI[sha256sum] = "6279836d581513a26f1bf235f9acd333bc9115683f14f7e8fae46c98fc
 inherit pypi python_hatchling
 
 DEPENDS += " \
-    ${PYTHON_PN}-hatch-vcs-native \
-    ${PYTHON_PN}-hatch-fancy-pypi-readme-native \
+    python3-hatch-vcs-native \
+    python3-hatch-fancy-pypi-readme-native \
 "
 
 RDEPENDS:${PN}+= " \
-    ${PYTHON_PN}-ctypes \
-    ${PYTHON_PN}-crypt \
+    python3-ctypes \
+    python3-crypt \
 "
 
 BBCLASSEXTEND = "native nativesdk"