diff mbox series

[13/20] python3-setuptools-rust: fix RDEPENDS and allow target build

Message ID 20230517080639.9336-14-brgl@bgdev.pl
State Accepted, archived
Commit aa8001e9bff9f9dd92a4a1ce435f1ae452e104c9
Headers show
Series python3: fix run-time dependencies | expand

Commit Message

Bartosz Golaszewski May 17, 2023, 8:06 a.m. UTC
From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>

Cargo and rustc can now be built for the target architecture. There's no
reason to limit the setuptools rust extensions to native build only so
make the RDEPENDS global. Also: add the missing ones.

Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
---
 .../python/python3-setuptools-rust_1.5.2.bb     | 17 ++++++++++-------
 1 file changed, 10 insertions(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-setuptools-rust_1.5.2.bb b/meta/recipes-devtools/python/python3-setuptools-rust_1.5.2.bb
index 502967fd20..01e29cc6d8 100644
--- a/meta/recipes-devtools/python/python3-setuptools-rust_1.5.2.bb
+++ b/meta/recipes-devtools/python/python3-setuptools-rust_1.5.2.bb
@@ -18,13 +18,16 @@  inherit cargo pypi python_setuptools_build_meta
 
 DEPENDS += "python3-setuptools-scm-native python3-wheel-native"
 
-RDEPENDS:${PN}:class-native += " \
-    python3-semantic-version-native \
-    python3-setuptools-native \
-    python3-setuptools-scm-native \
-    python3-toml-native \
-    python3-typing-extensions-native \
-    python3-wheel-native \
+RDEPENDS:${PN} += " \
+    python3-distutils \
+    python3-json \
+    python3-semantic-version \
+    python3-setuptools \
+    python3-setuptools-scm \
+    python3-shell \
+    python3-toml \
+    python3-typing-extensions \
+    python3-wheel \
 "
 
 BBCLASSEXTEND = "native"