diff mbox series

[meta-python,2/2] python3-httpx: Upgrade 0.26.0 -> 0.27.0

Message ID 20240322175608.160631-2-leon.anavi@konsulko.com
State Accepted
Headers show
Series [meta-python,1/2] python3-anyio: Upgrade 4.2.0 -> 4.3.0 | expand

Commit Message

Leon Anavi March 22, 2024, 5:56 p.m. UTC
Upgrade to version 0.27.0:

- The app=... shortcut has been deprecated. Use the explicit style
  of transport=httpx.WSGITransport() or transport=httpx.ASGITransport()
  instead.
- Respect the http1 argument while configuring proxy transports.
- Fix RFC 2069 mode digest authentication.

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../{python3-httpx_0.26.0.bb => python3-httpx_0.27.0.bb}    | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-httpx_0.26.0.bb => python3-httpx_0.27.0.bb} (81%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-httpx_0.26.0.bb b/meta-python/recipes-devtools/python/python3-httpx_0.27.0.bb
similarity index 81%
rename from meta-python/recipes-devtools/python/python3-httpx_0.26.0.bb
rename to meta-python/recipes-devtools/python/python3-httpx_0.27.0.bb
index 50bff7f85..e4d3cbeee 100644
--- a/meta-python/recipes-devtools/python/python3-httpx_0.26.0.bb
+++ b/meta-python/recipes-devtools/python/python3-httpx_0.27.0.bb
@@ -5,7 +5,7 @@  LIC_FILES_CHKSUM = "file://LICENSE.md;md5=c624803bdf6fc1c4ce39f5ae11d7bd05"
 
 inherit pypi python_hatchling
 
-SRC_URI[sha256sum] = "451b55c30d5185ea6b23c2c793abf9bb237d2a7dfb901ced6ff69ad37ec1dfaf"
+SRC_URI[sha256sum] = "a0cb88a46f32dc874e04ee956e4c2764aba2aa228f650b06788ba6bda2962ab5"
 
 DEPENDS += "\
     python3-hatch-fancy-pypi-readme-native \
@@ -22,6 +22,10 @@  RDEPENDS:${PN} += "\
     python3-httpcore \
     python3-idna \
     python3-sniffio \
+    python3-json \
+    python3-core \
+    python3-netclient \
+    python3-compression \
 "
 
 PACKAGES += "\