diff mbox series

[meta-python,1/2] python3-anyio: Upgrade 4.2.0 -> 4.3.0

Message ID 20240322175608.160631-1-leon.anavi@konsulko.com
State Accepted
Headers show
Series [meta-python,1/2] python3-anyio: Upgrade 4.2.0 -> 4.3.0 | expand

Commit Message

Leon Anavi March 22, 2024, 5:56 p.m. UTC
Upgrade to version 4.3.0:

- Added support for the Python 3.12 walk_up keyword argument in
  anyio.Path.relative_to() (PR by Colin Taylor)
- Fixed passing total_tokens to anyio.CapacityLimiter() as a
  keyword argument not working on the trio backend (#515)
- Fixed Process.aclose() not performing the minimum level of
  necessary cleanup when cancelled. Previously:
- Cancellation of Process.aclose() could leak an orphan process
- Cancellation of run_process() could very briefly leak an orphan
  process.
- Cancellation of Process.aclose() or run_process() on Trio could
  leave standard streams unclosed
- Fixed Process.stdin.aclose(), Process.stdout.aclose(), and
  Process.stderr.aclose() not including a checkpoint on asyncio
- Fixed documentation on how to provide your own typed attributes

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../{python3-anyio_4.2.0.bb => python3-anyio_4.3.0.bb}      | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-anyio_4.2.0.bb => python3-anyio_4.3.0.bb} (78%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-anyio_4.2.0.bb b/meta-python/recipes-devtools/python/python3-anyio_4.3.0.bb
similarity index 78%
rename from meta-python/recipes-devtools/python/python3-anyio_4.2.0.bb
rename to meta-python/recipes-devtools/python/python3-anyio_4.3.0.bb
index 0bf907de7..2c7a9f8ca 100644
--- a/meta-python/recipes-devtools/python/python3-anyio_4.2.0.bb
+++ b/meta-python/recipes-devtools/python/python3-anyio_4.3.0.bb
@@ -5,7 +5,7 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=c0a769411d2af7894099e8ff75058c9f"
 
 inherit pypi python_setuptools_build_meta
 
-SRC_URI[sha256sum] = "e1875bb4b4e2de1669f4bc7869b6d3f54231cdced71605e6e64c9be77e3be50f"
+SRC_URI[sha256sum] = "f75253795a87df48568485fd18cdd2a3fa5c4f7c5be8e5e36637733fce06fed6"
 
 DEPENDS += " \
 	python3-setuptools-scm-native \
@@ -20,4 +20,8 @@  DEPENDS += " \
 RDEPENDS:${PN} += "\
     python3-idna \
     python3-sniffio \
+    python3-core \
+    python3-numbers \
+    python3-io \
+    python3-asyncio \
 "