diff mbox series

[meta-python,4/5] python3-httpcore: add recipe for v1.0.2

Message ID 20240205125829.152301-5-dev@g0hl1n.net
State Accepted
Headers show
Series Add python3-httpx support | expand

Commit Message

Richard Leitner Feb. 5, 2024, 12:58 p.m. UTC
A minimal low-level HTTP client.

This recipe is currently provided without trio support, as the author
has no use for it and it would require to add a new python3-trio recipe.

This recipe uses pypi as source:

	https://pypi.org/project/httpcore

Signed-off-by: Richard Leitner <dev@g0hl1n.net>
---
 .../python/python3-httpcore_1.0.2.bb          | 26 +++++++++++++++++++
 1 file changed, 26 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-httpcore_1.0.2.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-httpcore_1.0.2.bb b/meta-python/recipes-devtools/python/python3-httpcore_1.0.2.bb
new file mode 100644
index 000000000..3bfe5ed4a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-httpcore_1.0.2.bb
@@ -0,0 +1,26 @@ 
+SUMMARY = "A minimal low-level HTTP client."
+SECTION = "devel/python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.md;md5=1c1f23b073da202e1f4f9e426490210c"
+
+inherit pypi python_hatchling
+
+SRC_URI[sha256sum] = "9fc092e4799b26174648e54b74ed5f683132a464e95643b226e00c2ed2fa6535"
+
+DEPENDS += "\
+    python3-hatch-fancy-pypi-readme-native \
+"
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[http2] = ",,,python3-h2"
+PACKAGECONFIG[socks] = ",,,python3-socksio"
+PACKAGECONFIG[asyncio] = ",,,python3-anyio"
+# Don't provide "trio" PACKAGECONFIG as nothing provides "python3-trio" currently.
+# If somebody needs this please feel free to add python3-trio and enable the
+# packageconfig below:
+#PACKAGECONFIG[trio] = ",,,python3-trio"
+
+RDEPENDS:${PN} += "\
+    python3-certifi \
+    python3-h11 \
+"