diff mbox series

[meta-python,1/5] python3-socksio: add recipe for v1.0.0

Message ID 20240205125829.152301-2-dev@g0hl1n.net
State Accepted
Headers show
Series Add python3-httpx support | expand

Commit Message

Richard Leitner Feb. 5, 2024, 12:58 p.m. UTC
Sans-I/O implementation of SOCKS4, SOCKS4A, and SOCKS5. This recipe uses
pypi as source:

	https://pypi.org/project/socksio

Signed-off-by: Richard Leitner <dev@g0hl1n.net>
---
 .../0001-Unpin-flit-core-dependency.patch     | 21 +++++++++++++++++++
 .../python/python3-socksio_1.0.0.bb           | 10 +++++++++
 2 files changed, 31 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-socksio/0001-Unpin-flit-core-dependency.patch
 create mode 100644 meta-python/recipes-devtools/python/python3-socksio_1.0.0.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-socksio/0001-Unpin-flit-core-dependency.patch b/meta-python/recipes-devtools/python/python3-socksio/0001-Unpin-flit-core-dependency.patch
new file mode 100644
index 000000000..75be61fc4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-socksio/0001-Unpin-flit-core-dependency.patch
@@ -0,0 +1,21 @@ 
+From 5c50fd76e7459bb822ff8f712172a78e21b8dd04 Mon Sep 17 00:00:00 2001
+From: Theodore Ni <3806110+tjni@users.noreply.github.com>
+Date: Sun, 13 Aug 2023 09:21:49 -0700
+Subject: [PATCH] Unpin flit-core dependency
+
+Upstream-Status: Submitted [https://github.com/sethmlarson/socksio/pull/61]
+---
+ pyproject.toml | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/pyproject.toml b/pyproject.toml
+index 2d6c5a3..60c63ea 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -1,5 +1,5 @@
+ [build-system]
+-requires = ["flit_core >=2,<3"]
++requires = ["flit_core >=2"]
+ build-backend = "flit_core.buildapi"
+ 
+ [tool.flit.metadata]
diff --git a/meta-python/recipes-devtools/python/python3-socksio_1.0.0.bb b/meta-python/recipes-devtools/python/python3-socksio_1.0.0.bb
new file mode 100644
index 000000000..4353a52ee
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-socksio_1.0.0.bb
@@ -0,0 +1,10 @@ 
+SUMMARY = "Sans-I/O implementation of SOCKS4, SOCKS4A, and SOCKS5."
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=0b4dda8edb09eec767aaded3cbf8f6b1"
+
+inherit pypi python_flit_core
+
+SRC_URI += "file://0001-Unpin-flit-core-dependency.patch"
+
+SRC_URI[sha256sum] = "f88beb3da5b5c38b9890469de67d0cb0f9d494b78b106ca1845f96c10b91c4ac"