diff mbox series

[meta-python,3/4] python3-pdm: add recipe

Message ID 20231107110848.1610779-3-leon.anavi@konsulko.com
State New
Headers show
Series [meta-python,1/4] python3-wand: add recipe | expand

Commit Message

Leon Anavi Nov. 7, 2023, 11:08 a.m. UTC
Add pdm, a modern Python package and dependency manager supporting
the latest PEP standards. Version 2.10.1 brings:

- Fix list index out of range when build error message is empty
- Fix find_link sources being exported as --extra--index-url
- Fix an installation failure when install.cache = true
- Fix a resolution issue that extra dependencies are not resolved
  when the bare dependency has more specific version constraint

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../recipes-devtools/python/python3-pdm_2.10.1.bb | 15 +++++++++++++++
 1 file changed, 15 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-pdm_2.10.1.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pdm_2.10.1.bb b/meta-python/recipes-devtools/python/python3-pdm_2.10.1.bb
new file mode 100644
index 000000000..d5aab3db7
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pdm_2.10.1.bb
@@ -0,0 +1,15 @@ 
+SUMMARY = "A modern Python package and dependency manager supporting the latest PEP standards"
+HOMEPAGE = "https://pdm-project.org/latest/"
+LICENSE = "MIT"
+SECTION = "devel/python"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2eb31a2cc1a758c34b499f287dd04ef2"
+
+SRC_URI[sha256sum] = "d166531c659fc4905933546544dd2e16cf648c2ba6d898c82126ad6a42117a81"
+
+inherit pypi python_setuptools_build_meta
+
+DEPENDS += " \
+    ${PYTHON_PN}-pdm-backend-native \
+"
+
+BBCLASSEXTEND = "native nativesdk"