diff mbox series

[meta-python,1/4] python3-wand: add recipe

Message ID 20231107110848.1610779-1-leon.anavi@konsulko.com
State New
Headers show
Series [meta-python,1/4] python3-wand: add recipe | expand

Commit Message

Leon Anavi Nov. 7, 2023, 11:08 a.m. UTC
Add Wand, a ctypes-based simple MagickWand API binding for Python.
Versions 0.6.13 and 0.6.12 provide:

- Hotfix release to remove a "work-in-progress" pyproject.toml
- Fixed behavior when passing zero to Image.chop()
- Fixed libmagick yield MagickCore library on Linux
- Fixed removing mask when passing None to Image.write_mask() method
- Added new COMPOSITE_OPERATORS operators

This work was sponsored by GOVCERT.LU.

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../python/python3-wand_0.6.13.bb                 | 15 +++++++++++++++
 1 file changed, 15 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-wand_0.6.13.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-wand_0.6.13.bb b/meta-python/recipes-devtools/python/python3-wand_0.6.13.bb
new file mode 100644
index 000000000..85e05ad97
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-wand_0.6.13.bb
@@ -0,0 +1,15 @@ 
+SUMMARY = "Ctypes-based simple MagickWand API binding for Python"
+HOMEPAGE = "https://docs.wand-py.org/"
+LICENSE = "MIT"
+SECTION = "devel/python"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=0bf19e5c00d047fee994ae332db3aab6"
+
+SRC_URI[sha256sum] = "f5013484eaf7a20eb22d1821aaefe60b50cc329722372b5f8565d46d4aaafcca"
+
+inherit pypi setuptools3
+
+PYPI_PACKAGE="Wand"
+
+FILES:${PN}-doc += "${datadir}/README.rst"
+
+BBCLASSEXTEND = "native nativesdk"