diff mbox series

[meta-python,4/4] python3-pytest-mock: disable broken ptests

Message ID 20231013170801.3966008-4-tgamblin@baylibre.com
State Under Review
Headers show
Series [meta-python,1/4] python-git-pw: add from meta-patchtest | expand

Commit Message

Trevor Gamblin Oct. 13, 2023, 5:08 p.m. UTC
Two introspection-related ptests are consistently failing. For now,
disable them so that a clean ptest run is available.

Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
---
 ...t_mock-skip-args-introspection-tests.patch | 38 +++++++++++++++++++
 .../python/python3-pytest-mock_3.11.1.bb      |  1 +
 2 files changed, 39 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-pytest-mock/0001-test_pytest_mock-skip-args-introspection-tests.patch

Comments

Khem Raj Oct. 13, 2023, 5:15 p.m. UTC | #1
On Fri, Oct 13, 2023 at 10:08 AM Trevor Gamblin <tgamblin@baylibre.com> wrote:
>
> Two introspection-related ptests are consistently failing. For now,
> disable them so that a clean ptest run is available.
>
For regular runs can we  move it out of PTESTS_PROBLEMS_META_PYTHON into
either PTESTS_FAST_META_PYTHON or PTESTS_SLOW_META_PYTHON

> Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
> ---
>  ...t_mock-skip-args-introspection-tests.patch | 38 +++++++++++++++++++
>  .../python/python3-pytest-mock_3.11.1.bb      |  1 +
>  2 files changed, 39 insertions(+)
>  create mode 100644 meta-python/recipes-devtools/python/python3-pytest-mock/0001-test_pytest_mock-skip-args-introspection-tests.patch
>
> diff --git a/meta-python/recipes-devtools/python/python3-pytest-mock/0001-test_pytest_mock-skip-args-introspection-tests.patch b/meta-python/recipes-devtools/python/python3-pytest-mock/0001-test_pytest_mock-skip-args-introspection-tests.patch
> new file mode 100644
> index 0000000000..f024e79d93
> --- /dev/null
> +++ b/meta-python/recipes-devtools/python/python3-pytest-mock/0001-test_pytest_mock-skip-args-introspection-tests.patch
> @@ -0,0 +1,38 @@
> +From e184fb950ad3b52c5c16438d39fe4d516c784e30 Mon Sep 17 00:00:00 2001
> +From: Trevor Gamblin <tgamblin@baylibre.com>
> +Date: Thu, 12 Oct 2023 17:32:40 -0400
> +Subject: [PATCH] test_pytest_mock: skip args introspection tests
> +
> +Disable these two tests for now so that python3-pytest-mock can have
> +successful ptest runs.
> +
> +Upstream-Status: Inappropriate [OE-Specific]
> +
> +Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
> +---
> + tests/test_pytest_mock.py | 2 ++
> + 1 file changed, 2 insertions(+)
> +
> +diff --git a/tests/test_pytest_mock.py b/tests/test_pytest_mock.py
> +index 3d53241..157b6c3 100644
> +--- a/tests/test_pytest_mock.py
> ++++ b/tests/test_pytest_mock.py
> +@@ -581,6 +581,7 @@ def test_assert_called_wrapper(mocker: MockerFixture) -> None:
> +     stub.assert_called()
> +
> +
> ++@pytest.mark.skip("Async not correctly detected, skip for now")
> + @pytest.mark.usefixtures("needs_assert_rewrite")
> + def test_assert_called_args_with_introspection(mocker: MockerFixture) -> None:
> +     stub = mocker.stub()
> +@@ -597,6 +598,7 @@ def test_assert_called_args_with_introspection(mocker: MockerFixture) -> None:
> +         stub.assert_called_once_with(*wrong_args)
> +
> +
> ++@pytest.mark.skip("Async not correctly detected, skip for now")
> + @pytest.mark.usefixtures("needs_assert_rewrite")
> + def test_assert_called_kwargs_with_introspection(mocker: MockerFixture) -> None:
> +     stub = mocker.stub()
> +--
> +2.41.0
> +
> diff --git a/meta-python/recipes-devtools/python/python3-pytest-mock_3.11.1.bb b/meta-python/recipes-devtools/python/python3-pytest-mock_3.11.1.bb
> index 69d74567c3..7fd998edc6 100644
> --- a/meta-python/recipes-devtools/python/python3-pytest-mock_3.11.1.bb
> +++ b/meta-python/recipes-devtools/python/python3-pytest-mock_3.11.1.bb
> @@ -8,6 +8,7 @@ LIC_FILES_CHKSUM = " \
>  SRC_URI = " \
>      git://github.com/pytest-dev/pytest-mock;branch=main;protocol=https \
>      file://run-ptest \
> +    file://0001-test_pytest_mock-skip-args-introspection-tests.patch \
>  "
>
>  SRCREV ?= "d3e73f2e93f7b93eba0a36e17e43bafd969da4fe"
> --
> 2.41.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#105483): https://lists.openembedded.org/g/openembedded-devel/message/105483
> Mute This Topic: https://lists.openembedded.org/mt/101944758/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Trevor Gamblin Oct. 13, 2023, 5:30 p.m. UTC | #2
On 2023-10-13 13:15, Khem Raj wrote:
> On Fri, Oct 13, 2023 at 10:08 AM Trevor Gamblin <tgamblin@baylibre.com> wrote:
>> Two introspection-related ptests are consistently failing. For now,
>> disable them so that a clean ptest run is available.
>>
> For regular runs can we  move it out of PTESTS_PROBLEMS_META_PYTHON into
> either PTESTS_FAST_META_PYTHON or PTESTS_SLOW_META_PYTHON
Done, sent a patch to move both recipes.
>
>> Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
>> ---
>>   ...t_mock-skip-args-introspection-tests.patch | 38 +++++++++++++++++++
>>   .../python/python3-pytest-mock_3.11.1.bb      |  1 +
>>   2 files changed, 39 insertions(+)
>>   create mode 100644 meta-python/recipes-devtools/python/python3-pytest-mock/0001-test_pytest_mock-skip-args-introspection-tests.patch
>>
>> diff --git a/meta-python/recipes-devtools/python/python3-pytest-mock/0001-test_pytest_mock-skip-args-introspection-tests.patch b/meta-python/recipes-devtools/python/python3-pytest-mock/0001-test_pytest_mock-skip-args-introspection-tests.patch
>> new file mode 100644
>> index 0000000000..f024e79d93
>> --- /dev/null
>> +++ b/meta-python/recipes-devtools/python/python3-pytest-mock/0001-test_pytest_mock-skip-args-introspection-tests.patch
>> @@ -0,0 +1,38 @@
>> +From e184fb950ad3b52c5c16438d39fe4d516c784e30 Mon Sep 17 00:00:00 2001
>> +From: Trevor Gamblin <tgamblin@baylibre.com>
>> +Date: Thu, 12 Oct 2023 17:32:40 -0400
>> +Subject: [PATCH] test_pytest_mock: skip args introspection tests
>> +
>> +Disable these two tests for now so that python3-pytest-mock can have
>> +successful ptest runs.
>> +
>> +Upstream-Status: Inappropriate [OE-Specific]
>> +
>> +Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
>> +---
>> + tests/test_pytest_mock.py | 2 ++
>> + 1 file changed, 2 insertions(+)
>> +
>> +diff --git a/tests/test_pytest_mock.py b/tests/test_pytest_mock.py
>> +index 3d53241..157b6c3 100644
>> +--- a/tests/test_pytest_mock.py
>> ++++ b/tests/test_pytest_mock.py
>> +@@ -581,6 +581,7 @@ def test_assert_called_wrapper(mocker: MockerFixture) -> None:
>> +     stub.assert_called()
>> +
>> +
>> ++@pytest.mark.skip("Async not correctly detected, skip for now")
>> + @pytest.mark.usefixtures("needs_assert_rewrite")
>> + def test_assert_called_args_with_introspection(mocker: MockerFixture) -> None:
>> +     stub = mocker.stub()
>> +@@ -597,6 +598,7 @@ def test_assert_called_args_with_introspection(mocker: MockerFixture) -> None:
>> +         stub.assert_called_once_with(*wrong_args)
>> +
>> +
>> ++@pytest.mark.skip("Async not correctly detected, skip for now")
>> + @pytest.mark.usefixtures("needs_assert_rewrite")
>> + def test_assert_called_kwargs_with_introspection(mocker: MockerFixture) -> None:
>> +     stub = mocker.stub()
>> +--
>> +2.41.0
>> +
>> diff --git a/meta-python/recipes-devtools/python/python3-pytest-mock_3.11.1.bb b/meta-python/recipes-devtools/python/python3-pytest-mock_3.11.1.bb
>> index 69d74567c3..7fd998edc6 100644
>> --- a/meta-python/recipes-devtools/python/python3-pytest-mock_3.11.1.bb
>> +++ b/meta-python/recipes-devtools/python/python3-pytest-mock_3.11.1.bb
>> @@ -8,6 +8,7 @@ LIC_FILES_CHKSUM = " \
>>   SRC_URI = " \
>>       git://github.com/pytest-dev/pytest-mock;branch=main;protocol=https \
>>       file://run-ptest \
>> +    file://0001-test_pytest_mock-skip-args-introspection-tests.patch \
>>   "
>>
>>   SRCREV ?= "d3e73f2e93f7b93eba0a36e17e43bafd969da4fe"
>> --
>> 2.41.0
>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#105483): https://lists.openembedded.org/g/openembedded-devel/message/105483
>> Mute This Topic: https://lists.openembedded.org/mt/101944758/1997914
>> Group Owner: openembedded-devel+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
Khem Raj Oct. 13, 2023, 5:33 p.m. UTC | #3
On 10/13/23 10:30 AM, Trevor Gamblin wrote:
> 
> On 2023-10-13 13:15, Khem Raj wrote:
>> On Fri, Oct 13, 2023 at 10:08 AM Trevor Gamblin 
>> <tgamblin@baylibre.com> wrote:
>>> Two introspection-related ptests are consistently failing. For now,
>>> disable them so that a clean ptest run is available.
>>>
>> For regular runs can we  move it out of PTESTS_PROBLEMS_META_PYTHON into
>> either PTESTS_FAST_META_PYTHON or PTESTS_SLOW_META_PYTHON
> Done, sent a patch to move both recipes.

Thanks, it will start running in my regular CI jobs now.

>>
>>> Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
>>> ---
>>>   ...t_mock-skip-args-introspection-tests.patch | 38 +++++++++++++++++++
>>>   .../python/python3-pytest-mock_3.11.1.bb      |  1 +
>>>   2 files changed, 39 insertions(+)
>>>   create mode 100644 
>>> meta-python/recipes-devtools/python/python3-pytest-mock/0001-test_pytest_mock-skip-args-introspection-tests.patch
>>>
>>> diff --git 
>>> a/meta-python/recipes-devtools/python/python3-pytest-mock/0001-test_pytest_mock-skip-args-introspection-tests.patch b/meta-python/recipes-devtools/python/python3-pytest-mock/0001-test_pytest_mock-skip-args-introspection-tests.patch
>>> new file mode 100644
>>> index 0000000000..f024e79d93
>>> --- /dev/null
>>> +++ 
>>> b/meta-python/recipes-devtools/python/python3-pytest-mock/0001-test_pytest_mock-skip-args-introspection-tests.patch
>>> @@ -0,0 +1,38 @@
>>> +From e184fb950ad3b52c5c16438d39fe4d516c784e30 Mon Sep 17 00:00:00 2001
>>> +From: Trevor Gamblin <tgamblin@baylibre.com>
>>> +Date: Thu, 12 Oct 2023 17:32:40 -0400
>>> +Subject: [PATCH] test_pytest_mock: skip args introspection tests
>>> +
>>> +Disable these two tests for now so that python3-pytest-mock can have
>>> +successful ptest runs.
>>> +
>>> +Upstream-Status: Inappropriate [OE-Specific]
>>> +
>>> +Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
>>> +---
>>> + tests/test_pytest_mock.py | 2 ++
>>> + 1 file changed, 2 insertions(+)
>>> +
>>> +diff --git a/tests/test_pytest_mock.py b/tests/test_pytest_mock.py
>>> +index 3d53241..157b6c3 100644
>>> +--- a/tests/test_pytest_mock.py
>>> ++++ b/tests/test_pytest_mock.py
>>> +@@ -581,6 +581,7 @@ def test_assert_called_wrapper(mocker: 
>>> MockerFixture) -> None:
>>> +     stub.assert_called()
>>> +
>>> +
>>> ++@pytest.mark.skip("Async not correctly detected, skip for now")
>>> + @pytest.mark.usefixtures("needs_assert_rewrite")
>>> + def test_assert_called_args_with_introspection(mocker: 
>>> MockerFixture) -> None:
>>> +     stub = mocker.stub()
>>> +@@ -597,6 +598,7 @@ def 
>>> test_assert_called_args_with_introspection(mocker: MockerFixture) -> 
>>> None:
>>> +         stub.assert_called_once_with(*wrong_args)
>>> +
>>> +
>>> ++@pytest.mark.skip("Async not correctly detected, skip for now")
>>> + @pytest.mark.usefixtures("needs_assert_rewrite")
>>> + def test_assert_called_kwargs_with_introspection(mocker: 
>>> MockerFixture) -> None:
>>> +     stub = mocker.stub()
>>> +--
>>> +2.41.0
>>> +
>>> diff --git 
>>> a/meta-python/recipes-devtools/python/python3-pytest-mock_3.11.1.bb 
>>> b/meta-python/recipes-devtools/python/python3-pytest-mock_3.11.1.bb
>>> index 69d74567c3..7fd998edc6 100644
>>> --- a/meta-python/recipes-devtools/python/python3-pytest-mock_3.11.1.bb
>>> +++ b/meta-python/recipes-devtools/python/python3-pytest-mock_3.11.1.bb
>>> @@ -8,6 +8,7 @@ LIC_FILES_CHKSUM = " \
>>>   SRC_URI = " \
>>>       
>>> git://github.com/pytest-dev/pytest-mock;branch=main;protocol=https \
>>>       file://run-ptest \
>>> +    file://0001-test_pytest_mock-skip-args-introspection-tests.patch \
>>>   "
>>>
>>>   SRCREV ?= "d3e73f2e93f7b93eba0a36e17e43bafd969da4fe"
>>> -- 
>>> 2.41.0
>>>
>>>
>>> -=-=-=-=-=-=-=-=-=-=-=-
>>> Links: You receive all messages sent to this group.
>>> View/Reply Online (#105483): 
>>> https://lists.openembedded.org/g/openembedded-devel/message/105483
>>> Mute This Topic: https://lists.openembedded.org/mt/101944758/1997914
>>> Group Owner: openembedded-devel+owner@lists.openembedded.org
>>> Unsubscribe: 
>>> https://lists.openembedded.org/g/openembedded-devel/unsub 
>>> [raj.khem@gmail.com]
>>> -=-=-=-=-=-=-=-=-=-=-=-
>>>
Khem Raj Oct. 13, 2023, 6:08 p.m. UTC | #4
Fails for me

AssertionError:
Failed ptests:
{'python3-pytest-mock':
['tests/test_pytest_mock.py::test_detailed_introspection_async',
                         'tests/test_pytest_mock.py::test_plain_stopall',

'tests/test_pytest_mock.py::test_used_with_class_scope',

'tests/test_pytest_mock.py::test_used_with_module_scope',

'tests/test_pytest_mock.py::test_used_with_package_scope',

'tests/test_pytest_mock.py::test_used_with_session_scope']}

here is detailed ptest log
https://snips.sh/f/abkZuQSUsK

On Fri, Oct 13, 2023 at 10:33 AM Khem Raj <raj.khem@gmail.com> wrote:
>
> On 10/13/23 10:30 AM, Trevor Gamblin wrote:
> >
> > On 2023-10-13 13:15, Khem Raj wrote:
> >> On Fri, Oct 13, 2023 at 10:08 AM Trevor Gamblin
> >> <tgamblin@baylibre.com> wrote:
> >>> Two introspection-related ptests are consistently failing. For now,
> >>> disable them so that a clean ptest run is available.
> >>>
> >> For regular runs can we  move it out of PTESTS_PROBLEMS_META_PYTHON into
> >> either PTESTS_FAST_META_PYTHON or PTESTS_SLOW_META_PYTHON
> > Done, sent a patch to move both recipes.
>
> Thanks, it will start running in my regular CI jobs now.
>
> >>
> >>> Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
> >>> ---
> >>>   ...t_mock-skip-args-introspection-tests.patch | 38 +++++++++++++++++++
> >>>   .../python/python3-pytest-mock_3.11.1.bb      |  1 +
> >>>   2 files changed, 39 insertions(+)
> >>>   create mode 100644
> >>> meta-python/recipes-devtools/python/python3-pytest-mock/0001-test_pytest_mock-skip-args-introspection-tests.patch
> >>>
> >>> diff --git
> >>> a/meta-python/recipes-devtools/python/python3-pytest-mock/0001-test_pytest_mock-skip-args-introspection-tests.patch b/meta-python/recipes-devtools/python/python3-pytest-mock/0001-test_pytest_mock-skip-args-introspection-tests.patch
> >>> new file mode 100644
> >>> index 0000000000..f024e79d93
> >>> --- /dev/null
> >>> +++
> >>> b/meta-python/recipes-devtools/python/python3-pytest-mock/0001-test_pytest_mock-skip-args-introspection-tests.patch
> >>> @@ -0,0 +1,38 @@
> >>> +From e184fb950ad3b52c5c16438d39fe4d516c784e30 Mon Sep 17 00:00:00 2001
> >>> +From: Trevor Gamblin <tgamblin@baylibre.com>
> >>> +Date: Thu, 12 Oct 2023 17:32:40 -0400
> >>> +Subject: [PATCH] test_pytest_mock: skip args introspection tests
> >>> +
> >>> +Disable these two tests for now so that python3-pytest-mock can have
> >>> +successful ptest runs.
> >>> +
> >>> +Upstream-Status: Inappropriate [OE-Specific]
> >>> +
> >>> +Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
> >>> +---
> >>> + tests/test_pytest_mock.py | 2 ++
> >>> + 1 file changed, 2 insertions(+)
> >>> +
> >>> +diff --git a/tests/test_pytest_mock.py b/tests/test_pytest_mock.py
> >>> +index 3d53241..157b6c3 100644
> >>> +--- a/tests/test_pytest_mock.py
> >>> ++++ b/tests/test_pytest_mock.py
> >>> +@@ -581,6 +581,7 @@ def test_assert_called_wrapper(mocker:
> >>> MockerFixture) -> None:
> >>> +     stub.assert_called()
> >>> +
> >>> +
> >>> ++@pytest.mark.skip("Async not correctly detected, skip for now")
> >>> + @pytest.mark.usefixtures("needs_assert_rewrite")
> >>> + def test_assert_called_args_with_introspection(mocker:
> >>> MockerFixture) -> None:
> >>> +     stub = mocker.stub()
> >>> +@@ -597,6 +598,7 @@ def
> >>> test_assert_called_args_with_introspection(mocker: MockerFixture) ->
> >>> None:
> >>> +         stub.assert_called_once_with(*wrong_args)
> >>> +
> >>> +
> >>> ++@pytest.mark.skip("Async not correctly detected, skip for now")
> >>> + @pytest.mark.usefixtures("needs_assert_rewrite")
> >>> + def test_assert_called_kwargs_with_introspection(mocker:
> >>> MockerFixture) -> None:
> >>> +     stub = mocker.stub()
> >>> +--
> >>> +2.41.0
> >>> +
> >>> diff --git
> >>> a/meta-python/recipes-devtools/python/python3-pytest-mock_3.11.1.bb
> >>> b/meta-python/recipes-devtools/python/python3-pytest-mock_3.11.1.bb
> >>> index 69d74567c3..7fd998edc6 100644
> >>> --- a/meta-python/recipes-devtools/python/python3-pytest-mock_3.11.1.bb
> >>> +++ b/meta-python/recipes-devtools/python/python3-pytest-mock_3.11.1.bb
> >>> @@ -8,6 +8,7 @@ LIC_FILES_CHKSUM = " \
> >>>   SRC_URI = " \
> >>>
> >>> git://github.com/pytest-dev/pytest-mock;branch=main;protocol=https \
> >>>       file://run-ptest \
> >>> +    file://0001-test_pytest_mock-skip-args-introspection-tests.patch \
> >>>   "
> >>>
> >>>   SRCREV ?= "d3e73f2e93f7b93eba0a36e17e43bafd969da4fe"
> >>> --
> >>> 2.41.0
> >>>
> >>>
> >>> -=-=-=-=-=-=-=-=-=-=-=-
> >>> Links: You receive all messages sent to this group.
> >>> View/Reply Online (#105483):
> >>> https://lists.openembedded.org/g/openembedded-devel/message/105483
> >>> Mute This Topic: https://lists.openembedded.org/mt/101944758/1997914
> >>> Group Owner: openembedded-devel+owner@lists.openembedded.org
> >>> Unsubscribe:
> >>> https://lists.openembedded.org/g/openembedded-devel/unsub
> >>> [raj.khem@gmail.com]
> >>> -=-=-=-=-=-=-=-=-=-=-=-
> >>>
Trevor Gamblin Oct. 13, 2023, 6:29 p.m. UTC | #5
On 2023-10-13 14:08, Khem Raj wrote:
> Fails for me
>
> AssertionError:
> Failed ptests:
> {'python3-pytest-mock':
> ['tests/test_pytest_mock.py::test_detailed_introspection_async',
>                           'tests/test_pytest_mock.py::test_plain_stopall',
>
> 'tests/test_pytest_mock.py::test_used_with_class_scope',
>
> 'tests/test_pytest_mock.py::test_used_with_module_scope',
>
> 'tests/test_pytest_mock.py::test_used_with_package_scope',
>
> 'tests/test_pytest_mock.py::test_used_with_session_scope']}
>
> here is detailed ptest log
> https://snips.sh/f/abkZuQSUsK
Weird. Can you take the python3-git-pw and python3-arrow recipes, and 
I'll take a look at these?
>
> On Fri, Oct 13, 2023 at 10:33 AM Khem Raj <raj.khem@gmail.com> wrote:
>> On 10/13/23 10:30 AM, Trevor Gamblin wrote:
>>> On 2023-10-13 13:15, Khem Raj wrote:
>>>> On Fri, Oct 13, 2023 at 10:08 AM Trevor Gamblin
>>>> <tgamblin@baylibre.com> wrote:
>>>>> Two introspection-related ptests are consistently failing. For now,
>>>>> disable them so that a clean ptest run is available.
>>>>>
>>>> For regular runs can we  move it out of PTESTS_PROBLEMS_META_PYTHON into
>>>> either PTESTS_FAST_META_PYTHON or PTESTS_SLOW_META_PYTHON
>>> Done, sent a patch to move both recipes.
>> Thanks, it will start running in my regular CI jobs now.
>>
>>>>> Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
>>>>> ---
>>>>>    ...t_mock-skip-args-introspection-tests.patch | 38 +++++++++++++++++++
>>>>>    .../python/python3-pytest-mock_3.11.1.bb      |  1 +
>>>>>    2 files changed, 39 insertions(+)
>>>>>    create mode 100644
>>>>> meta-python/recipes-devtools/python/python3-pytest-mock/0001-test_pytest_mock-skip-args-introspection-tests.patch
>>>>>
>>>>> diff --git
>>>>> a/meta-python/recipes-devtools/python/python3-pytest-mock/0001-test_pytest_mock-skip-args-introspection-tests.patch b/meta-python/recipes-devtools/python/python3-pytest-mock/0001-test_pytest_mock-skip-args-introspection-tests.patch
>>>>> new file mode 100644
>>>>> index 0000000000..f024e79d93
>>>>> --- /dev/null
>>>>> +++
>>>>> b/meta-python/recipes-devtools/python/python3-pytest-mock/0001-test_pytest_mock-skip-args-introspection-tests.patch
>>>>> @@ -0,0 +1,38 @@
>>>>> +From e184fb950ad3b52c5c16438d39fe4d516c784e30 Mon Sep 17 00:00:00 2001
>>>>> +From: Trevor Gamblin <tgamblin@baylibre.com>
>>>>> +Date: Thu, 12 Oct 2023 17:32:40 -0400
>>>>> +Subject: [PATCH] test_pytest_mock: skip args introspection tests
>>>>> +
>>>>> +Disable these two tests for now so that python3-pytest-mock can have
>>>>> +successful ptest runs.
>>>>> +
>>>>> +Upstream-Status: Inappropriate [OE-Specific]
>>>>> +
>>>>> +Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
>>>>> +---
>>>>> + tests/test_pytest_mock.py | 2 ++
>>>>> + 1 file changed, 2 insertions(+)
>>>>> +
>>>>> +diff --git a/tests/test_pytest_mock.py b/tests/test_pytest_mock.py
>>>>> +index 3d53241..157b6c3 100644
>>>>> +--- a/tests/test_pytest_mock.py
>>>>> ++++ b/tests/test_pytest_mock.py
>>>>> +@@ -581,6 +581,7 @@ def test_assert_called_wrapper(mocker:
>>>>> MockerFixture) -> None:
>>>>> +     stub.assert_called()
>>>>> +
>>>>> +
>>>>> ++@pytest.mark.skip("Async not correctly detected, skip for now")
>>>>> + @pytest.mark.usefixtures("needs_assert_rewrite")
>>>>> + def test_assert_called_args_with_introspection(mocker:
>>>>> MockerFixture) -> None:
>>>>> +     stub = mocker.stub()
>>>>> +@@ -597,6 +598,7 @@ def
>>>>> test_assert_called_args_with_introspection(mocker: MockerFixture) ->
>>>>> None:
>>>>> +         stub.assert_called_once_with(*wrong_args)
>>>>> +
>>>>> +
>>>>> ++@pytest.mark.skip("Async not correctly detected, skip for now")
>>>>> + @pytest.mark.usefixtures("needs_assert_rewrite")
>>>>> + def test_assert_called_kwargs_with_introspection(mocker:
>>>>> MockerFixture) -> None:
>>>>> +     stub = mocker.stub()
>>>>> +--
>>>>> +2.41.0
>>>>> +
>>>>> diff --git
>>>>> a/meta-python/recipes-devtools/python/python3-pytest-mock_3.11.1.bb
>>>>> b/meta-python/recipes-devtools/python/python3-pytest-mock_3.11.1.bb
>>>>> index 69d74567c3..7fd998edc6 100644
>>>>> --- a/meta-python/recipes-devtools/python/python3-pytest-mock_3.11.1.bb
>>>>> +++ b/meta-python/recipes-devtools/python/python3-pytest-mock_3.11.1.bb
>>>>> @@ -8,6 +8,7 @@ LIC_FILES_CHKSUM = " \
>>>>>    SRC_URI = " \
>>>>>
>>>>> git://github.com/pytest-dev/pytest-mock;branch=main;protocol=https \
>>>>>        file://run-ptest \
>>>>> +    file://0001-test_pytest_mock-skip-args-introspection-tests.patch \
>>>>>    "
>>>>>
>>>>>    SRCREV ?= "d3e73f2e93f7b93eba0a36e17e43bafd969da4fe"
>>>>> --
>>>>> 2.41.0
>>>>>
>>>>>
>>>>> -=-=-=-=-=-=-=-=-=-=-=-
>>>>> Links: You receive all messages sent to this group.
>>>>> View/Reply Online (#105483):
>>>>> https://lists.openembedded.org/g/openembedded-devel/message/105483
>>>>> Mute This Topic: https://lists.openembedded.org/mt/101944758/1997914
>>>>> Group Owner: openembedded-devel+owner@lists.openembedded.org
>>>>> Unsubscribe:
>>>>> https://lists.openembedded.org/g/openembedded-devel/unsub
>>>>> [raj.khem@gmail.com]
>>>>> -=-=-=-=-=-=-=-=-=-=-=-
>>>>>
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pytest-mock/0001-test_pytest_mock-skip-args-introspection-tests.patch b/meta-python/recipes-devtools/python/python3-pytest-mock/0001-test_pytest_mock-skip-args-introspection-tests.patch
new file mode 100644
index 0000000000..f024e79d93
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-mock/0001-test_pytest_mock-skip-args-introspection-tests.patch
@@ -0,0 +1,38 @@ 
+From e184fb950ad3b52c5c16438d39fe4d516c784e30 Mon Sep 17 00:00:00 2001
+From: Trevor Gamblin <tgamblin@baylibre.com>
+Date: Thu, 12 Oct 2023 17:32:40 -0400
+Subject: [PATCH] test_pytest_mock: skip args introspection tests
+
+Disable these two tests for now so that python3-pytest-mock can have
+successful ptest runs.
+
+Upstream-Status: Inappropriate [OE-Specific]
+
+Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
+---
+ tests/test_pytest_mock.py | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/tests/test_pytest_mock.py b/tests/test_pytest_mock.py
+index 3d53241..157b6c3 100644
+--- a/tests/test_pytest_mock.py
++++ b/tests/test_pytest_mock.py
+@@ -581,6 +581,7 @@ def test_assert_called_wrapper(mocker: MockerFixture) -> None:
+     stub.assert_called()
+ 
+ 
++@pytest.mark.skip("Async not correctly detected, skip for now")
+ @pytest.mark.usefixtures("needs_assert_rewrite")
+ def test_assert_called_args_with_introspection(mocker: MockerFixture) -> None:
+     stub = mocker.stub()
+@@ -597,6 +598,7 @@ def test_assert_called_args_with_introspection(mocker: MockerFixture) -> None:
+         stub.assert_called_once_with(*wrong_args)
+ 
+ 
++@pytest.mark.skip("Async not correctly detected, skip for now")
+ @pytest.mark.usefixtures("needs_assert_rewrite")
+ def test_assert_called_kwargs_with_introspection(mocker: MockerFixture) -> None:
+     stub = mocker.stub()
+-- 
+2.41.0
+
diff --git a/meta-python/recipes-devtools/python/python3-pytest-mock_3.11.1.bb b/meta-python/recipes-devtools/python/python3-pytest-mock_3.11.1.bb
index 69d74567c3..7fd998edc6 100644
--- a/meta-python/recipes-devtools/python/python3-pytest-mock_3.11.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pytest-mock_3.11.1.bb
@@ -8,6 +8,7 @@  LIC_FILES_CHKSUM = " \
 SRC_URI = " \
     git://github.com/pytest-dev/pytest-mock;branch=main;protocol=https \
     file://run-ptest \
+    file://0001-test_pytest_mock-skip-args-introspection-tests.patch \
 "
 
 SRCREV ?= "d3e73f2e93f7b93eba0a36e17e43bafd969da4fe"