diff mbox series

[meta-python,2/4] python3-arrow: add from meta-patchtest

Message ID 20231013170801.3966008-2-tgamblin@baylibre.com
State Under Review
Headers show
Series [meta-python,1/4] python-git-pw: add from meta-patchtest | expand

Commit Message

Trevor Gamblin Oct. 13, 2023, 5:07 p.m. UTC
arrow is a module that aims to provide a more user-friendly approach to
date and time in Python. It is required by git-pw which in turn is
required by patchtest, so add a recipe for it. The version is updated
1.2.2 -> 1.3.0 from the meta-patchtest layer.

Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
---
 .../recipes-devtools/python/python3-arrow_1.3.0.bb  | 13 +++++++++++++
 1 file changed, 13 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-arrow_1.3.0.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-arrow_1.3.0.bb b/meta-python/recipes-devtools/python/python3-arrow_1.3.0.bb
new file mode 100644
index 0000000000..ec49d04eb9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-arrow_1.3.0.bb
@@ -0,0 +1,13 @@ 
+SUMMARY = "Better dates and times for Python"
+HOMEPAGE = "https://github.com/crsmithdev/arrow"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=14a2e29a9d542fb9052d75344d67619d"
+
+SRC_URI[sha256sum] = "d4540617648cb5f895730f1ad8c82a65f2dad0166f57b75f3ca54759c4d67a85"
+
+inherit setuptools3 pypi
+
+RDEPENDS:${PN} += " \
+        ${PYTHON_PN}-dateutil \
+        "