diff mbox series

[meta-python,RESEND,01/54] python3-pywbem: drop unneeded class from RDEPENDS

Message ID 20230619132214.213417-2-brgl@bgdev.pl
State New
Headers show
Series python3: improve run-time dependencies situation | expand

Commit Message

Bartosz Golaszewski June 19, 2023, 1:21 p.m. UTC
From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>

The native package has the same dependencies. Even if normally they are
satisfied by python3-native, we should still use a global RDEPENDS.

Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
---
 meta-python/recipes-extended/pywbem/python3-pywbem_1.6.1.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Khem Raj June 20, 2023, 1:15 a.m. UTC | #1
On 6/19/23 6:21 AM, Bartosz Golaszewski wrote:
> From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
> 
> The native package has the same dependencies. Even if normally they are
> satisfied by python3-native, we should still use a global RDEPENDS.
> 

This will deepen the dependency list for native packages. Why should we 
do this ?

> Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
> ---
>   meta-python/recipes-extended/pywbem/python3-pywbem_1.6.1.bb | 2 +-
>   1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/meta-python/recipes-extended/pywbem/python3-pywbem_1.6.1.bb b/meta-python/recipes-extended/pywbem/python3-pywbem_1.6.1.bb
> index 71af06881..8b0383cf6 100644
> --- a/meta-python/recipes-extended/pywbem/python3-pywbem_1.6.1.bb
> +++ b/meta-python/recipes-extended/pywbem/python3-pywbem_1.6.1.bb
> @@ -27,7 +27,7 @@ DEPENDS += " \
>       ${PYTHON_PN}-wheel-native \
>   "
>   
> -RDEPENDS:${PN}:class-target += "\
> +RDEPENDS:${PN} += "\
>       ${PYTHON_PN}-datetime \
>       ${PYTHON_PN}-io \
>       ${PYTHON_PN}-netclient \
Khem Raj June 20, 2023, 6:03 p.m. UTC | #2
here are some failures

https://autobuilder.yoctoproject.org/typhoon/#/builders/88/builds/2841

On Mon, Jun 19, 2023 at 6:16 PM Khem Raj <raj.khem@gmail.com> wrote:
>
> On 6/19/23 6:21 AM, Bartosz Golaszewski wrote:
> > From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
> >
> > The native package has the same dependencies. Even if normally they are
> > satisfied by python3-native, we should still use a global RDEPENDS.
> >
>
> This will deepen the dependency list for native packages. Why should we
> do this ?
>
> > Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
> > ---
> >   meta-python/recipes-extended/pywbem/python3-pywbem_1.6.1.bb | 2 +-
> >   1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/meta-python/recipes-extended/pywbem/python3-pywbem_1.6.1.bb b/meta-python/recipes-extended/pywbem/python3-pywbem_1.6.1.bb
> > index 71af06881..8b0383cf6 100644
> > --- a/meta-python/recipes-extended/pywbem/python3-pywbem_1.6.1.bb
> > +++ b/meta-python/recipes-extended/pywbem/python3-pywbem_1.6.1.bb
> > @@ -27,7 +27,7 @@ DEPENDS += " \
> >       ${PYTHON_PN}-wheel-native \
> >   "
> >
> > -RDEPENDS:${PN}:class-target += "\
> > +RDEPENDS:${PN} += "\
> >       ${PYTHON_PN}-datetime \
> >       ${PYTHON_PN}-io \
> >       ${PYTHON_PN}-netclient \
Khem Raj June 20, 2023, 6:14 p.m. UTC | #3
Some more dep failures on parse

23:11:18 ERROR: Nothing RPROVIDES 'python3-nocasedict-native' (but
virtual:native:/mnt/jenkins/workspace/Yocto-world-musl/sources/meta-openembedded/meta-python/recipes-extended/pywbem/python3-pywbem_1.6.1.bb
RDEPENDS on or otherwise requires it)
23:11:18 NOTE: Runtime target 'python3-nocasedict-native' is
unbuildable, removing...
23:11:18 Missing or unbuildable dependency chain was:
['python3-nocasedict-native']
23:11:18 NOTE: Runtime target 'python3-pywbemtools-dev' is
unbuildable, removing...
23:11:18 Missing or unbuildable dependency chain was:
['python3-pywbemtools-dev', 'python3-pywbem-native',
'python3-nocasedict-native']
23:11:19 NOTE: Runtime target 'python3-pywbemtools' is unbuildable, removing...
23:11:19 Missing or unbuildable dependency chain was:
['python3-pywbemtools', 'python3-pywbem-native',
'python3-nocasedict-native']
23:11:23 ERROR: Nothing RPROVIDES 'python3-nocaselist-native' (but
virtual:native:/mnt/jenkins/workspace/Yocto-world-musl/sources/meta-openembedded/meta-python/recipes-extended/pywbem/python3-pywbem_1.6.1.bb
RDEPENDS on or otherwise requires it)
23:11:23 NOTE: Runtime target 'python3-nocaselist-native' is
unbuildable, removing...
23:11:23 Missing or unbuildable dependency chain was:
['python3-nocaselist-native']
23:11:28 ERROR: Nothing RPROVIDES 'python3-yamlloader-native' (but
virtual:native:/mnt/jenkins/workspace/Yocto-world-musl/sources/meta-openembedded/meta-python/recipes-extended/pywbem/python3-pywbem_1.6.1.bb
RDEPENDS on or otherwise requires it)
23:11:28 NOTE: Runtime target 'python3-yamlloader-native' is
unbuildable, removing...
23:11:28 Missing or unbuildable dependency chain was:
['python3-yamlloader-native']

On Tue, Jun 20, 2023 at 11:03 AM Khem Raj <raj.khem@gmail.com> wrote:
>
> here are some failures
>
> https://autobuilder.yoctoproject.org/typhoon/#/builders/88/builds/2841
>
> On Mon, Jun 19, 2023 at 6:16 PM Khem Raj <raj.khem@gmail.com> wrote:
> >
> > On 6/19/23 6:21 AM, Bartosz Golaszewski wrote:
> > > From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
> > >
> > > The native package has the same dependencies. Even if normally they are
> > > satisfied by python3-native, we should still use a global RDEPENDS.
> > >
> >
> > This will deepen the dependency list for native packages. Why should we
> > do this ?
> >
> > > Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
> > > ---
> > >   meta-python/recipes-extended/pywbem/python3-pywbem_1.6.1.bb | 2 +-
> > >   1 file changed, 1 insertion(+), 1 deletion(-)
> > >
> > > diff --git a/meta-python/recipes-extended/pywbem/python3-pywbem_1.6.1.bb b/meta-python/recipes-extended/pywbem/python3-pywbem_1.6.1.bb
> > > index 71af06881..8b0383cf6 100644
> > > --- a/meta-python/recipes-extended/pywbem/python3-pywbem_1.6.1.bb
> > > +++ b/meta-python/recipes-extended/pywbem/python3-pywbem_1.6.1.bb
> > > @@ -27,7 +27,7 @@ DEPENDS += " \
> > >       ${PYTHON_PN}-wheel-native \
> > >   "
> > >
> > > -RDEPENDS:${PN}:class-target += "\
> > > +RDEPENDS:${PN} += "\
> > >       ${PYTHON_PN}-datetime \
> > >       ${PYTHON_PN}-io \
> > >       ${PYTHON_PN}-netclient \
Bartosz Golaszewski June 21, 2023, 9:50 a.m. UTC | #4
On Tue, Jun 20, 2023 at 8:15 PM Khem Raj <raj.khem@gmail.com> wrote:
>
> Some more dep failures on parse
>
> 23:11:18 ERROR: Nothing RPROVIDES 'python3-nocasedict-native' (but
> virtual:native:/mnt/jenkins/workspace/Yocto-world-musl/sources/meta-openembedded/meta-python/recipes-extended/pywbem/python3-pywbem_1.6.1.bb
> RDEPENDS on or otherwise requires it)
> 23:11:18 NOTE: Runtime target 'python3-nocasedict-native' is
> unbuildable, removing...
> 23:11:18 Missing or unbuildable dependency chain was:
> ['python3-nocasedict-native']
> 23:11:18 NOTE: Runtime target 'python3-pywbemtools-dev' is
> unbuildable, removing...
> 23:11:18 Missing or unbuildable dependency chain was:
> ['python3-pywbemtools-dev', 'python3-pywbem-native',
> 'python3-nocasedict-native']
> 23:11:19 NOTE: Runtime target 'python3-pywbemtools' is unbuildable, removing...
> 23:11:19 Missing or unbuildable dependency chain was:
> ['python3-pywbemtools', 'python3-pywbem-native',
> 'python3-nocasedict-native']
> 23:11:23 ERROR: Nothing RPROVIDES 'python3-nocaselist-native' (but
> virtual:native:/mnt/jenkins/workspace/Yocto-world-musl/sources/meta-openembedded/meta-python/recipes-extended/pywbem/python3-pywbem_1.6.1.bb
> RDEPENDS on or otherwise requires it)
> 23:11:23 NOTE: Runtime target 'python3-nocaselist-native' is
> unbuildable, removing...
> 23:11:23 Missing or unbuildable dependency chain was:
> ['python3-nocaselist-native']
> 23:11:28 ERROR: Nothing RPROVIDES 'python3-yamlloader-native' (but
> virtual:native:/mnt/jenkins/workspace/Yocto-world-musl/sources/meta-openembedded/meta-python/recipes-extended/pywbem/python3-pywbem_1.6.1.bb
> RDEPENDS on or otherwise requires it)
> 23:11:28 NOTE: Runtime target 'python3-yamlloader-native' is
> unbuildable, removing...
> 23:11:28 Missing or unbuildable dependency chain was:
> ['python3-yamlloader-native']
>

Feel free to drop this and whichever other patches cause failures, I
will look at whatever remains after this round.

Bart

> On Tue, Jun 20, 2023 at 11:03 AM Khem Raj <raj.khem@gmail.com> wrote:
> >
> > here are some failures
> >
> > https://autobuilder.yoctoproject.org/typhoon/#/builders/88/builds/2841
> >
> > On Mon, Jun 19, 2023 at 6:16 PM Khem Raj <raj.khem@gmail.com> wrote:
> > >
> > > On 6/19/23 6:21 AM, Bartosz Golaszewski wrote:
> > > > From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
> > > >
> > > > The native package has the same dependencies. Even if normally they are
> > > > satisfied by python3-native, we should still use a global RDEPENDS.
> > > >
> > >
> > > This will deepen the dependency list for native packages. Why should we
> > > do this ?
> > >
> > > > Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
> > > > ---
> > > >   meta-python/recipes-extended/pywbem/python3-pywbem_1.6.1.bb | 2 +-
> > > >   1 file changed, 1 insertion(+), 1 deletion(-)
> > > >
> > > > diff --git a/meta-python/recipes-extended/pywbem/python3-pywbem_1.6.1.bb b/meta-python/recipes-extended/pywbem/python3-pywbem_1.6.1.bb
> > > > index 71af06881..8b0383cf6 100644
> > > > --- a/meta-python/recipes-extended/pywbem/python3-pywbem_1.6.1.bb
> > > > +++ b/meta-python/recipes-extended/pywbem/python3-pywbem_1.6.1.bb
> > > > @@ -27,7 +27,7 @@ DEPENDS += " \
> > > >       ${PYTHON_PN}-wheel-native \
> > > >   "
> > > >
> > > > -RDEPENDS:${PN}:class-target += "\
> > > > +RDEPENDS:${PN} += "\
> > > >       ${PYTHON_PN}-datetime \
> > > >       ${PYTHON_PN}-io \
> > > >       ${PYTHON_PN}-netclient \
Khem Raj June 21, 2023, 2:43 p.m. UTC | #5
I have dropped whole series it will be good to send a new one with these
fixed you can do

Bitbake world -n to see some of dep and parsing fails

On Wed, Jun 21, 2023 at 2:51 AM Bartosz Golaszewski <brgl@bgdev.pl> wrote:

> On Tue, Jun 20, 2023 at 8:15 PM Khem Raj <raj.khem@gmail.com> wrote:
> >
> > Some more dep failures on parse
> >
> > 23:11:18 ERROR: Nothing RPROVIDES 'python3-nocasedict-native' (but
> >
> virtual:native:/mnt/jenkins/workspace/Yocto-world-musl/sources/meta-openembedded/meta-python/recipes-extended/pywbem/
> python3-pywbem_1.6.1.bb
> > RDEPENDS on or otherwise requires it)
> > 23:11:18 NOTE: Runtime target 'python3-nocasedict-native' is
> > unbuildable, removing...
> > 23:11:18 Missing or unbuildable dependency chain was:
> > ['python3-nocasedict-native']
> > 23:11:18 NOTE: Runtime target 'python3-pywbemtools-dev' is
> > unbuildable, removing...
> > 23:11:18 Missing or unbuildable dependency chain was:
> > ['python3-pywbemtools-dev', 'python3-pywbem-native',
> > 'python3-nocasedict-native']
> > 23:11:19 NOTE: Runtime target 'python3-pywbemtools' is unbuildable,
> removing...
> > 23:11:19 Missing or unbuildable dependency chain was:
> > ['python3-pywbemtools', 'python3-pywbem-native',
> > 'python3-nocasedict-native']
> > 23:11:23 ERROR: Nothing RPROVIDES 'python3-nocaselist-native' (but
> >
> virtual:native:/mnt/jenkins/workspace/Yocto-world-musl/sources/meta-openembedded/meta-python/recipes-extended/pywbem/
> python3-pywbem_1.6.1.bb
> > RDEPENDS on or otherwise requires it)
> > 23:11:23 NOTE: Runtime target 'python3-nocaselist-native' is
> > unbuildable, removing...
> > 23:11:23 Missing or unbuildable dependency chain was:
> > ['python3-nocaselist-native']
> > 23:11:28 ERROR: Nothing RPROVIDES 'python3-yamlloader-native' (but
> >
> virtual:native:/mnt/jenkins/workspace/Yocto-world-musl/sources/meta-openembedded/meta-python/recipes-extended/pywbem/
> python3-pywbem_1.6.1.bb
> > RDEPENDS on or otherwise requires it)
> > 23:11:28 NOTE: Runtime target 'python3-yamlloader-native' is
> > unbuildable, removing...
> > 23:11:28 Missing or unbuildable dependency chain was:
> > ['python3-yamlloader-native']
> >
>
> Feel free to drop this and whichever other patches cause failures, I
> will look at whatever remains after this round.
>
> Bart
>
> > On Tue, Jun 20, 2023 at 11:03 AM Khem Raj <raj.khem@gmail.com> wrote:
> > >
> > > here are some failures
> > >
> > > https://autobuilder.yoctoproject.org/typhoon/#/builders/88/builds/2841
> > >
> > > On Mon, Jun 19, 2023 at 6:16 PM Khem Raj <raj.khem@gmail.com> wrote:
> > > >
> > > > On 6/19/23 6:21 AM, Bartosz Golaszewski wrote:
> > > > > From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
> > > > >
> > > > > The native package has the same dependencies. Even if normally
> they are
> > > > > satisfied by python3-native, we should still use a global RDEPENDS.
> > > > >
> > > >
> > > > This will deepen the dependency list for native packages. Why should
> we
> > > > do this ?
> > > >
> > > > > Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org
> >
> > > > > ---
> > > > >   meta-python/recipes-extended/pywbem/python3-pywbem_1.6.1.bb | 2
> +-
> > > > >   1 file changed, 1 insertion(+), 1 deletion(-)
> > > > >
> > > > > diff --git a/meta-python/recipes-extended/pywbem/
> python3-pywbem_1.6.1.bb b/meta-python/recipes-extended/pywbem/
> python3-pywbem_1.6.1.bb
> > > > > index 71af06881..8b0383cf6 100644
> > > > > --- a/meta-python/recipes-extended/pywbem/python3-pywbem_1.6.1.bb
> > > > > +++ b/meta-python/recipes-extended/pywbem/python3-pywbem_1.6.1.bb
> > > > > @@ -27,7 +27,7 @@ DEPENDS += " \
> > > > >       ${PYTHON_PN}-wheel-native \
> > > > >   "
> > > > >
> > > > > -RDEPENDS:${PN}:class-target += "\
> > > > > +RDEPENDS:${PN} += "\
> > > > >       ${PYTHON_PN}-datetime \
> > > > >       ${PYTHON_PN}-io \
> > > > >       ${PYTHON_PN}-netclient \
>
diff mbox series

Patch

diff --git a/meta-python/recipes-extended/pywbem/python3-pywbem_1.6.1.bb b/meta-python/recipes-extended/pywbem/python3-pywbem_1.6.1.bb
index 71af06881..8b0383cf6 100644
--- a/meta-python/recipes-extended/pywbem/python3-pywbem_1.6.1.bb
+++ b/meta-python/recipes-extended/pywbem/python3-pywbem_1.6.1.bb
@@ -27,7 +27,7 @@  DEPENDS += " \
     ${PYTHON_PN}-wheel-native \
 "
 
-RDEPENDS:${PN}:class-target += "\
+RDEPENDS:${PN} += "\
     ${PYTHON_PN}-datetime \
     ${PYTHON_PN}-io \
     ${PYTHON_PN}-netclient \