diff mbox series

[meta-python,5/5] python3-term: Upgrade 2.3 -> 2.4

Message ID 20220817153538.3853497-5-leon.anavi@konsulko.com
State Accepted, archived
Headers show
Series [meta-python,1/5] python3-cytoolz: Upgrade 0.11.2 -> 0.12.0 | expand

Commit Message

Leon Anavi Aug. 17, 2022, 3:35 p.m. UTC
Upgrade to release 2.4:

- Add Python 3.8-3.10 to tox.ini. Remove old Python versions.
- Replace deprecated python setup.py test in tox.ini.
- Remove deprecated test_suite from setup.py.
- Move metadata to setup.cfg and add a pyproject.toml file.
- Include tests in sdist but not in wheel.
- Fix escape sequence warning in byte string literal.
- Open /dev/tty in binary mode under both Python 2 and 3.
- Officially change opentty's bufsize argument default from 1 to
  -1. Under Python 3, 1 has effectively meant -1 all along but
  Python 3.8 now issues a warning.
- Add readto, getfgcolor, getbgcolor, islightmode, and isdarkmode.

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../python/{python3-term_2.3.bb => python3-term_2.4.bb}  | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-term_2.3.bb => python3-term_2.4.bb} (54%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-term_2.3.bb b/meta-python/recipes-devtools/python/python3-term_2.4.bb
similarity index 54%
rename from meta-python/recipes-devtools/python/python3-term_2.3.bb
rename to meta-python/recipes-devtools/python/python3-term_2.4.bb
index 6b62eb02c..bc6a4c3df 100644
--- a/meta-python/recipes-devtools/python/python3-term_2.3.bb
+++ b/meta-python/recipes-devtools/python/python3-term_2.4.bb
@@ -3,9 +3,10 @@  SECTION = "devel/python"
 LICENSE = "Python-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=d90e2d280a4836c607520383d1639be1"
 
-SRC_URI[md5sum] = "ab0c1bce381b1109fe4390c56aa06237"
-SRC_URI[sha256sum] = "3dcc8c212e04700784e5c1c5b601916ba0549ae6025b35b64fd62144899e7180"
-
-PYPI_PACKAGE_EXT = "zip"
+SRC_URI[sha256sum] = "2cca4cf5f83035ca12627c4bbeff2891ad4711666247a790fd8200d73f38c3f0"
 
 inherit pypi setuptools3
+
+RDEPENDS:${PN} = "\
+    ${PYTHON_PN}-io \
+"