diff mbox series

[meta-python,3/5] python3-pyperf: Upgrade 2.3.0 -> 2.4.1

Message ID 20220817153538.3853497-3-leon.anavi@konsulko.com
State Accepted, archived
Headers show
Series [meta-python,1/5] python3-cytoolz: Upgrade 0.11.2 -> 0.12.0 | expand

Commit Message

Leon Anavi Aug. 17, 2022, 3:35 p.m. UTC
Upgrade to release 2.4.1:

- Reject --tracemalloc in pyperf command
- Support reporting geometric mean by benchmark tags
- Add pyston as an implementation with a jit
- Add support for profiling benchmarks

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../{python3-pyperf_2.3.0.bb => python3-pyperf_2.4.1.bb}      | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-pyperf_2.3.0.bb => python3-pyperf_2.4.1.bb} (82%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pyperf_2.3.0.bb b/meta-python/recipes-devtools/python/python3-pyperf_2.4.1.bb
similarity index 82%
rename from meta-python/recipes-devtools/python/python3-pyperf_2.3.0.bb
rename to meta-python/recipes-devtools/python/python3-pyperf_2.4.1.bb
index 5172b0a05..cb8282566 100644
--- a/meta-python/recipes-devtools/python/python3-pyperf_2.3.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pyperf_2.4.1.bb
@@ -13,11 +13,11 @@  Features: \
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://COPYING;md5=78bc2e6e87c8c61272937b879e6dc2f8"
 
-SRC_URI[sha256sum] = "8a85dd42e067131d5b26b71472336da7f7f4b87ff9c97350d89f5ff0de9adedc"
+SRC_URI[sha256sum] = "38cf5e90c56f906a8320ce82a50bfa92c902b93affd72e4dc81580115f355853"
 
 DEPENDS += "${PYTHON_PN}-six-native"
 
 PYPI_PACKAGE = "pyperf"
 inherit pypi setuptools3
 
-RDEPENDS:${PN} += "${PYTHON_PN}-misc"
+RDEPENDS:${PN} += "${PYTHON_PN}-misc ${PYTHON_PN}-statistics"