diff mbox series

[meta-oe,48/49] webkitgtk3: upgrade 2.44.0 -> 2.44.1

Message ID 1713318061-17128-48-git-send-email-wangmy@fujitsu.com
State New
Headers show
Series [meta-oe,01/49] abseil-cpp: upgrade 20240116.1 -> 20240116.2 | expand

Commit Message

Mingyu Wang (Fujitsu) April 17, 2024, 1:41 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

2922af379dc70b4b1a63b01d67179eb431f03ac4.patch
removed since it's included in 2.44.1

Changelog:
==========
- Fix handling of lifetime of web view child dialogs in GTK4.
- Do not schedule layer flushes when drawing area size is empty.
- Fix videos with alpha when using the DMA-BUF sink.
- Fix the build with USE_GBM=OFF.
- Fix the build in 32bit platforms
- Fix several crashes and rendering issues.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 ...af379dc70b4b1a63b01d67179eb431f03ac4.patch | 36 -------------------
 ...kitgtk3_2.44.0.bb => webkitgtk3_2.44.1.bb} |  3 +-
 2 files changed, 1 insertion(+), 38 deletions(-)
 delete mode 100644 meta-oe/recipes-support/webkitgtk/webkitgtk3/2922af379dc70b4b1a63b01d67179eb431f03ac4.patch
 rename meta-oe/recipes-support/webkitgtk/{webkitgtk3_2.44.0.bb => webkitgtk3_2.44.1.bb} (98%)
diff mbox series

Patch

diff --git a/meta-oe/recipes-support/webkitgtk/webkitgtk3/2922af379dc70b4b1a63b01d67179eb431f03ac4.patch b/meta-oe/recipes-support/webkitgtk/webkitgtk3/2922af379dc70b4b1a63b01d67179eb431f03ac4.patch
deleted file mode 100644
index 0f6b9a633..000000000
--- a/meta-oe/recipes-support/webkitgtk/webkitgtk3/2922af379dc70b4b1a63b01d67179eb431f03ac4.patch
+++ /dev/null
@@ -1,36 +0,0 @@ 
-From 2922af379dc70b4b1a63b01d67179eb431f03ac4 Mon Sep 17 00:00:00 2001
-From: Michael Catanzaro <mcatanzaro@redhat.com>
-Date: Mon, 18 Mar 2024 11:14:54 -0700
-Subject: [PATCH] REGRESSION(274077@main): failure to build on i586 (and likely
- other 32bit arches): static assertion failed: Timer should stay small
- https://bugs.webkit.org/show_bug.cgi?id=271108
-
-Unreviewed build fix. This changes SameSizeOfTimer to ensure it matches
-the size of Timer on 32-bit platforms.
-
-* Source/WebCore/platform/Timer.cpp:
-
-Canonical link: https://commits.webkit.org/276282@main
-
-Upstream-Status: Backport [https://github.com/WebKit/WebKit/commit/2922af379dc70b4b1a63b01d67179eb431f03ac4]
----
- Source/WebCore/platform/Timer.cpp | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/Source/WebCore/platform/Timer.cpp b/Source/WebCore/platform/Timer.cpp
-index 4f7c0f5c39ca9..0f3734cca2474 100644
---- a/Source/WebCore/platform/Timer.cpp
-+++ b/Source/WebCore/platform/Timer.cpp
-@@ -263,7 +263,11 @@ struct SameSizeAsTimer {
- 
-     WeakPtr<TimerAlignment> timerAlignment;
-     double times[2];
--    void* pointers[3];
-+    void* pointers[2];
-+#if CPU(ADDRESS32)
-+    uint8_t bitfields;
-+#endif
-+    void* pointer;
- };
- 
- static_assert(sizeof(Timer) == sizeof(SameSizeAsTimer), "Timer should stay small");
diff --git a/meta-oe/recipes-support/webkitgtk/webkitgtk3_2.44.0.bb b/meta-oe/recipes-support/webkitgtk/webkitgtk3_2.44.1.bb
similarity index 98%
rename from meta-oe/recipes-support/webkitgtk/webkitgtk3_2.44.0.bb
rename to meta-oe/recipes-support/webkitgtk/webkitgtk3_2.44.1.bb
index 34afaed9d..fc96d5dc3 100644
--- a/meta-oe/recipes-support/webkitgtk/webkitgtk3_2.44.0.bb
+++ b/meta-oe/recipes-support/webkitgtk/webkitgtk3_2.44.1.bb
@@ -15,9 +15,8 @@  SRC_URI = "https://www.webkitgtk.org/releases/webkitgtk-${PV}.tar.xz \
            file://no-musttail-arm.patch \
            file://0001-LowLevelInterpreter.cpp-339-21-error-t6-was-not-decl.patch \
            file://30e1d5e22213fdaca2a29ec3400c927d710a37a8.patch \
-           file://2922af379dc70b4b1a63b01d67179eb431f03ac4.patch \
            "
-SRC_URI[sha256sum] = "c66530e41ba59b1edba4ee89ef20b2188e273bed0497e95084729e3cfbe30c87"
+SRC_URI[sha256sum] = "425b1459b0f04d0600c78d1abb5e7edfa3c060a420f8b231e9a6a2d5d29c5561"
 
 inherit cmake pkgconfig gobject-introspection perlnative features_check upstream-version-is-even gi-docgen