diff mbox series

[meta-python,18/49] python3-django: upgrade 5.0.3 -> 5.0.4

Message ID 1713318061-17128-18-git-send-email-wangmy@fujitsu.com
State New
Headers show
Series [meta-oe,01/49] abseil-cpp: upgrade 20240116.1 -> 20240116.2 | expand

Commit Message

Mingyu Wang (Fujitsu) April 17, 2024, 1:40 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
===========
* Fixed a bug in Django 5.0 that caused a crash of "Model.full_clean()" on
  fields with expressions in "db_default". As a consequence,
  "Model.full_clean()" no longer validates for empty values in fields with
  "db_default"
* Fixed a regression in Django 5.0 where the "AdminFileWidget" could be
  rendered with two "id" attributes on the "Clear" checkbox
* Fixed a bug in Django 5.0 that caused a migration crash on PostgreSQL 15+
  when adding a partial "UniqueConstraint" with "nulls_distinct"
* Fixed a crash in Django 5.0 when performing queries involving table aliases
  and lookups on a "GeneratedField" of the aliased table
* Fixed a bug in Django 5.0 that caused a migration crash when adding a
  "GeneratedField" relying on the "__contains" or "__icontains"
  lookups or using a "Value" containing a ""%""

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../python/{python3-django_5.0.3.bb => python3-django_5.0.4.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-django_5.0.3.bb => python3-django_5.0.4.bb} (56%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-django_5.0.3.bb b/meta-python/recipes-devtools/python/python3-django_5.0.4.bb
similarity index 56%
rename from meta-python/recipes-devtools/python/python3-django_5.0.3.bb
rename to meta-python/recipes-devtools/python/python3-django_5.0.4.bb
index 14c41a626..3139ed468 100644
--- a/meta-python/recipes-devtools/python/python3-django_5.0.3.bb
+++ b/meta-python/recipes-devtools/python/python3-django_5.0.4.bb
@@ -1,7 +1,7 @@ 
 require python-django.inc
 inherit setuptools3
 
-SRC_URI[sha256sum] = "5fb37580dcf4a262f9258c1f4373819aacca906431f505e4688e37f3a99195df"
+SRC_URI[sha256sum] = "4bd01a8c830bb77a8a3b0e7d8b25b887e536ad17a81ba2dce5476135c73312bd"
 
 RDEPENDS:${PN} += "\
     python3-sqlparse \