diff mbox series

[02/20] python3-attrs: unify RDEPENDS

Message ID 20230517080639.9336-3-brgl@bgdev.pl
State Accepted, archived
Commit aaaeffe8fca578abcbc19bbb306ff4a8b21bb59e
Headers show
Series python3: fix run-time dependencies | expand

Commit Message

Bartosz Golaszewski May 17, 2023, 8:06 a.m. UTC
From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>

The nativesdk and target RDEPENDS are the same and there's nothing that
prohibits this package from build built for the native sysroot either.
Use the global RDEPENDS instead of per-class assignments.

While at it: order the dependencies alphabetically.

Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
---
 meta/recipes-devtools/python/python3-attrs_23.1.0.bb | 6 +-----
 1 file changed, 1 insertion(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-attrs_23.1.0.bb b/meta/recipes-devtools/python/python3-attrs_23.1.0.bb
index c8e2e514a4..207636d62e 100644
--- a/meta/recipes-devtools/python/python3-attrs_23.1.0.bb
+++ b/meta/recipes-devtools/python/python3-attrs_23.1.0.bb
@@ -12,13 +12,9 @@  DEPENDS += " \
     ${PYTHON_PN}-hatch-fancy-pypi-readme-native \
 "
 
-RDEPENDS:${PN}:class-target += " \
-    ${PYTHON_PN}-crypt \
+RDEPENDS:${PN}+= " \
     ${PYTHON_PN}-ctypes \
-"
-RDEPENDS:${PN}:class-nativesdk += " \
     ${PYTHON_PN}-crypt \
-    ${PYTHON_PN}-ctypes \
 "
 
 BBCLASSEXTEND = "native nativesdk"