diff mbox series

[11/20] python3-installer: add missing run-time dependencies

Message ID 20230517080639.9336-12-brgl@bgdev.pl
State Accepted, archived
Commit 85ca038b00ce2406ae0e9bb66bee7e544d333537
Headers show
Series python3: fix run-time dependencies | expand

Commit Message

Bartosz Golaszewski May 17, 2023, 8:06 a.m. UTC
From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>

Add missing RDEPENDS for this package.

Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
---
 meta/recipes-devtools/python/python3-installer_0.7.0.bb | 6 ++++++
 1 file changed, 6 insertions(+)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-installer_0.7.0.bb b/meta/recipes-devtools/python/python3-installer_0.7.0.bb
index d7f1e79a5c..9429705b1f 100644
--- a/meta/recipes-devtools/python/python3-installer_0.7.0.bb
+++ b/meta/recipes-devtools/python/python3-installer_0.7.0.bb
@@ -15,6 +15,12 @@  inherit pypi python_flit_core
 # Bootstrap the native build
 DEPENDS:remove:class-native = "python3-build-native python3-installer-native"
 
+RDEPENDS:${PN} += " \
+    python3-compile \
+    python3-compression \
+    python3-netclient \
+"
+
 INSTALL_WHEEL_COMPILE_BYTECODE:class-native = "--no-compile-bytecode"
 
 do_compile:class-native () {