diff mbox series

[07/11] python3-more-itertools: upgrade 8.14.0 -> 9.0.0

Message ID 20221102031830.3606777-7-tim.orling@konsulko.com
State Accepted, archived
Commit f31ea2784428114acae33522a80208aa35d133bc
Headers show
Series [01/11] python3-bcrypt: upgrade 4.0.0 -> 4.0.1 | expand

Commit Message

Tim Orling Nov. 2, 2022, 3:18 a.m. UTC
https://github.com/more-itertools/more-itertools/blob/master/docs/versions.rst#900

9.0.0

* Potentially breaking changes
  - `grouper` no longer accepts an integer as its first
    argument. Previously this raised a DeprecationWarning.
  - `collate` has been removed. Use the built-in
    `heapq.merge` instead.
  - `windowed` now yields nothing when its iterable is
     empty.

* This library now advertises support for Python 3.7+.

* New functions
  - `constrained_batches`
  - `batched` (from the Python itertools docs)
  - `polynomial_from_roots` (from the Python itertools
     docs)
  -`sieve` (from the Python itertools docs)

* Other changes
  - Some documentation issues were fixed (thanks to nanouasyn)

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
---
 ...more-itertools_8.14.0.bb => python3-more-itertools_9.0.0.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta/recipes-devtools/python/{python3-more-itertools_8.14.0.bb => python3-more-itertools_9.0.0.bb} (86%)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-more-itertools_8.14.0.bb b/meta/recipes-devtools/python/python3-more-itertools_9.0.0.bb
similarity index 86%
rename from meta/recipes-devtools/python/python3-more-itertools_8.14.0.bb
rename to meta/recipes-devtools/python/python3-more-itertools_9.0.0.bb
index c955f93d9b2..fce3aea8977 100644
--- a/meta/recipes-devtools/python/python3-more-itertools_8.14.0.bb
+++ b/meta/recipes-devtools/python/python3-more-itertools_9.0.0.bb
@@ -3,7 +3,7 @@  HOMEPAGE = "https://github.com/erikrose/more-itertools"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=3396ea30f9d21389d7857719816f83b5"
 
-SRC_URI[sha256sum] = "c09443cd3d5438b8dafccd867a6bc1cb0894389e90cb53d227456b0b0bccb750"
+SRC_URI[sha256sum] = "5a6257e40878ef0520b1803990e3e22303a41b5714006c32a3fd8304b26ea1ab"
 
 inherit pypi python_flit_core ptest