diff mbox series

[10/11] python3-typing-extensions: upgrade 4.3.0 -> 4.4.0

Message ID 20221102031830.3606777-10-tim.orling@konsulko.com
State Accepted, archived
Commit 15ca091ae01ae298c013e8cf82ee6af382259ed8
Headers show
Series [01/11] python3-bcrypt: upgrade 4.0.0 -> 4.0.1 | expand

Commit Message

Tim Orling Nov. 2, 2022, 3:18 a.m. UTC
https://github.com/python/typing_extensions/blob/main/CHANGELOG.md#release-440-october-6-2022

Release 4.4.0 (October 6, 2022)

* Add typing_extensions.Any a backport of python 3.11's Any class
  which is subclassable at runtime. (backport from python/cpython#31841,
  by Shantanu and Jelle Zijlstra). Patch by James Hilton-Balfe
  (@Gobot1234).
* Add initial support for TypeVarLike default parameter, PEP 696.
  Patch by Marc Mueller (@cdce8p).
* Runtime support for PEP 698, adding typing_extensions.override.
  Patch by Jelle Zijlstra.
* Add the infer_variance parameter to TypeVar, as specified in PEP
  695. Patch by Jelle Zijlstra.

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
---
 .../python/python3-typing-extensions_4.3.0.bb | 14 ----
 .../python/python3-typing-extensions_4.4.0.bb | 69 +++++++++++++++++++
 2 files changed, 69 insertions(+), 14 deletions(-)
 delete mode 100644 meta/recipes-devtools/python/python3-typing-extensions_4.3.0.bb
 create mode 100644 meta/recipes-devtools/python/python3-typing-extensions_4.4.0.bb

Comments

Richard Purdie Nov. 3, 2022, 7:48 a.m. UTC | #1
On Tue, 2022-11-01 at 20:18 -0700, Tim Orling wrote:
> diff --git a/meta/recipes-devtools/python/python3-typing-extensions_4.4.0.bb b/meta/recipes-devtools/python/python3-typing-extensions_4.4.0.bb
> new file mode 100644
> index 00000000000..c8cbb215f04
> --- /dev/null
> +++ b/meta/recipes-devtools/python/python3-typing-extensions_4.4.0.bb
> @@ -0,0 +1,69 @@
> +# FIXME: the LIC_FILES_CHKSUM values have been updated by 'devtool upgrade'.
> +# The following is the difference between the old and the new license text.
> +# Please update the LICENSE value if needed, and summarize the changes in
> +# the commit message via 'License-Update:' tag.
> +# (example: 'License-Update: copyright years updated.')

[...]

Whilst this surprisingly made it through Alexandre's queue, I think
there may be a change needed here! ;-)

Cheers,

Richard
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-typing-extensions_4.3.0.bb b/meta/recipes-devtools/python/python3-typing-extensions_4.3.0.bb
deleted file mode 100644
index 9638491eb44..00000000000
--- a/meta/recipes-devtools/python/python3-typing-extensions_4.3.0.bb
+++ /dev/null
@@ -1,14 +0,0 @@ 
-HOMEPAGE = "https://github.com/python/typing"
-LICENSE = "PSF-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=64fc2b30b67d0a8423c250e0386ed72f"
-
-# The name on PyPi is slightly different.
-PYPI_PACKAGE = "typing_extensions"
-
-SRC_URI[sha256sum] = "e6d2677a32f47fc7eb2795db1dd15c1f34eff616bcaf2cfb5e997f854fa1c4a6"
-
-inherit pypi python_flit_core
-
-BBCLASSEXTEND = "native nativesdk"
-
-UPSTREAM_CHECK_REGEX = "/typing-extensions/(?P<pver>(\d+[\.\-_]*)+)/"
diff --git a/meta/recipes-devtools/python/python3-typing-extensions_4.4.0.bb b/meta/recipes-devtools/python/python3-typing-extensions_4.4.0.bb
new file mode 100644
index 00000000000..c8cbb215f04
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-typing-extensions_4.4.0.bb
@@ -0,0 +1,69 @@ 
+# FIXME: the LIC_FILES_CHKSUM values have been updated by 'devtool upgrade'.
+# The following is the difference between the old and the new license text.
+# Please update the LICENSE value if needed, and summarize the changes in
+# the commit message via 'License-Update:' tag.
+# (example: 'License-Update: copyright years updated.')
+#
+# The changes:
+#
+# --- LICENSE
+# +++ LICENSE
+# @@ -13,12 +13,11 @@
+#  
+#  In May 2000, Guido and the Python core development team moved to
+#  BeOpen.com to form the BeOpen PythonLabs team.  In October of the same
+# -year, the PythonLabs team moved to Digital Creations (now Zope
+# -Corporation, see http://www.zope.com).  In 2001, the Python Software
+# -Foundation (PSF, see http://www.python.org/psf/) was formed, a
+# -non-profit organization created specifically to own Python-related
+# -Intellectual Property.  Zope Corporation is a sponsoring member of
+# -the PSF.
+# +year, the PythonLabs team moved to Digital Creations, which became
+# +Zope Corporation.  In 2001, the Python Software Foundation (PSF, see
+# +https://www.python.org/psf/) was formed, a non-profit organization
+# +created specifically to own Python-related Intellectual Property.
+# +Zope Corporation was a sponsoring member of the PSF.
+#  
+#  All Python releases are Open Source (see http://www.opensource.org for
+#  the Open Source Definition).  Historically, most, but not all, Python
+# @@ -74,8 +73,9 @@
+#  distribute, and otherwise use Python alone or in any derivative version,
+#  provided, however, that PSF's License Agreement and PSF's notice of copyright,
+#  i.e., "Copyright (c) 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010,
+# -2011, 2012, 2013, 2014 Python Software Foundation; All Rights Reserved" are
+# -retained in Python alone or in any derivative version prepared by Licensee.
+# +2011, 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2021, 2022 Python Software Foundation;
+# +All Rights Reserved" are retained in Python alone or in any derivative version
+# +prepared by Licensee.
+#  
+#  3. In the event Licensee prepares a derivative work that is based on
+#  or incorporates Python or any part thereof, and wants to make
+# @@ -180,9 +180,9 @@
+#  Agreement, Licensee may substitute the following text (omitting the
+#  quotes): "Python 1.6.1 is made available subject to the terms and
+#  conditions in CNRI's License Agreement.  This Agreement together with
+# -Python 1.6.1 may be located on the Internet using the following
+# +Python 1.6.1 may be located on the internet using the following
+#  unique, persistent identifier (known as a handle): 1895.22/1013.  This
+# -Agreement may also be obtained from a proxy server on the Internet
+# +Agreement may also be obtained from a proxy server on the internet
+#  using the following URL: http://hdl.handle.net/1895.22/1013".
+#  
+#  3. In the event Licensee prepares a derivative work that is based on
+# 
+#
+
+HOMEPAGE = "https://github.com/python/typing"
+LICENSE = "PSF-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=f16b323917992e0f8a6f0071bc9913e2"
+
+# The name on PyPi is slightly different.
+PYPI_PACKAGE = "typing_extensions"
+
+SRC_URI[sha256sum] = "1511434bb92bf8dd198c12b1cc812e800d4181cfcb867674e0f8279cc93087aa"
+
+inherit pypi python_flit_core
+
+BBCLASSEXTEND = "native nativesdk"
+
+UPSTREAM_CHECK_REGEX = "/typing-extensions/(?P<pver>(\d+[\.\-_]*)+)/"