[4/6] flit_core: add variable to control where pyproject.toml is located

Message ID 20220308143035.3569559-4-ross.burton@arm.com
State Accepted, archived
Commit f85b512e2ad39ec32f11f9b25b8c92bea20c844d
Headers show
Series [1/6] flit_core: respect PIP_INSTALL_DIST_PATH | expand

Commit Message

Ross Burton March 8, 2022, 2:30 p.m. UTC
The PEP517[1] pyproject.toml doesn't have to be located at the top-level
of the source tree (for example, in recipes with multiple components), so
add a variable PEP517_SOURCE_PATH to set where the file is.

In the future there should be a pep517.bbclass to centralise the common
logic, but for now this can be defined in each of the relevant classes.

[1] https://www.python.org/dev/peps/pep-0517/

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta/classes/flit_core.bbclass | 4 ++++
 1 file changed, 4 insertions(+)

Patch

diff --git a/meta/classes/flit_core.bbclass b/meta/classes/flit_core.bbclass
index 3481bb5089..7b578967a9 100644
--- a/meta/classes/flit_core.bbclass
+++ b/meta/classes/flit_core.bbclass
@@ -6,8 +6,12 @@  flit_core_do_configure () {
     :
 }
 
+# Where to execute the build process from
+PEP517_SOURCE_PATH ?= "${S}"
+
 # TODO: ideally this uses pypa/build
 flit_core_do_compile () {
+    cd ${PEP517_SOURCE_PATH}
     nativepython3 -mflit_core.wheel --outdir ${PIP_INSTALL_DIST_PATH}
 }
 do_compile[cleandirs] += "${PIP_INSTALL_DIST_PATH}"