[2/6] setuptools3: respect PIP_INSTALL_DIST_PATH

Message ID 20220308143035.3569559-2-ross.burton@arm.com
State Accepted, archived
Commit 12857a77ad424c3c3cbc37275374a603e528d9f1
Headers show
Series [1/6] flit_core: respect PIP_INSTALL_DIST_PATH | expand

Commit Message

Ross Burton March 8, 2022, 2:30 p.m. UTC
pip_install_wheel expects the wheels to be in PIP_INSTALL_DIST_PATH but
this class was writing to the same directory through chance not design.

Respect PIP_INSTALL_DIST_PATH as the output directory.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta/classes/setuptools3.bbclass | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Patch

diff --git a/meta/classes/setuptools3.bbclass b/meta/classes/setuptools3.bbclass
index 1b1a8aac76..dcf3561b8d 100644
--- a/meta/classes/setuptools3.bbclass
+++ b/meta/classes/setuptools3.bbclass
@@ -17,11 +17,11 @@  setuptools3_do_compile() {
         STAGING_INCDIR=${STAGING_INCDIR} \
         STAGING_LIBDIR=${STAGING_LIBDIR} \
         ${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN} setup.py \
-        bdist_wheel --verbose ${SETUPTOOLS_BUILD_ARGS} || \
+        bdist_wheel --verbose --dist-dir ${PIP_INSTALL_DIST_PATH} ${SETUPTOOLS_BUILD_ARGS} || \
         bbfatal_log "'${PYTHON_PN} setup.py bdist_wheel ${SETUPTOOLS_BUILD_ARGS}' execution failed."
 }
 setuptools3_do_compile[vardepsexclude] = "MACHINE"
-do_compile[cleandirs] += "${SETUPTOOLS_SETUP_PATH}/dist"
+do_compile[cleandirs] += "${PIP_INSTALL_DIST_PATH}"
 
 setuptools3_do_install() {
         pip_install_wheel_do_install