diff mbox series

[07/34] glslang: upgrade 1.3.275.0 -> 1.3.280.0

Message ID 1711413292-3025-7-git-send-email-wangmy@fujitsu.com
State New
Headers show
Series [01/34] adwaita-icon-theme: upgrade 45.0 -> 46.0 | expand

Commit Message

Mingyu Wang (Fujitsu) March 26, 2024, 12:34 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

0001-generate-glslang-pkg-config.patch
refreshed for 1.3.280.0.

Changelog:
==========
* Add a new --abosute-path command-line option to output absolute paths in error messages
* Support GL_EXT_control_flow_attributes2
* Support GL_ARB_shading_language_include
* Fix HLSL built-in passthrough via inout
* Enable -Wimplicit-fallthrough and fix warnings
* Fix -Wmissing_field_initializer warnings
* Document supported dependencies in known_good.json
* Clear spirv vector before use
* Emit debug info for accelerationStructure and rayQuery variables
* Support NV_shader_atomic_fp16_vector
* Support GL_EXT_expect_assume_support
* Allow external control of whether glslang will be tested or installed
* Improve debug source and line info
* Support GL_KHR_shader_subgroup_rotate
* Add SPIRV-Tools-opt dependency if ENABLE_OPT
* Support EXT_shader_quad_control
* Add OpAssumeTrueKHR and OpExpectKHR
* Support GL_EXT_maximal_reconvergence
* Remove generation of deprecated Target.cmake files
* Fix array size of gl_SampleMask and gl_SampleMaskIn
* Support GL_ARB_texture_multisample_extension
* Emit DebugTypePointer when non-semantic debug info is enabled

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../glslang/0001-generate-glslang-pkg-config.patch     | 10 +++++-----
 .../{glslang_1.3.275.0.bb => glslang_1.3.280.0.bb}     |  2 +-
 2 files changed, 6 insertions(+), 6 deletions(-)
 rename meta/recipes-graphics/glslang/{glslang_1.3.275.0.bb => glslang_1.3.280.0.bb} (96%)

Comments

Alexander Kanavin March 26, 2024, 8:44 a.m. UTC | #1
This and the spirv recipes should be updated in lockstep with vulkan
recipes to keep them all at the same version. Please note that this is
written in the comments in all those recipes.

Alex


On Tue, 26 Mar 2024 at 01:35, wangmy via lists.openembedded.org
<wangmy=fujitsu.com@lists.openembedded.org> wrote:
>
> From: Wang Mingyu <wangmy@fujitsu.com>
>
> 0001-generate-glslang-pkg-config.patch
> refreshed for 1.3.280.0.
>
> Changelog:
> ==========
> * Add a new --abosute-path command-line option to output absolute paths in error messages
> * Support GL_EXT_control_flow_attributes2
> * Support GL_ARB_shading_language_include
> * Fix HLSL built-in passthrough via inout
> * Enable -Wimplicit-fallthrough and fix warnings
> * Fix -Wmissing_field_initializer warnings
> * Document supported dependencies in known_good.json
> * Clear spirv vector before use
> * Emit debug info for accelerationStructure and rayQuery variables
> * Support NV_shader_atomic_fp16_vector
> * Support GL_EXT_expect_assume_support
> * Allow external control of whether glslang will be tested or installed
> * Improve debug source and line info
> * Support GL_KHR_shader_subgroup_rotate
> * Add SPIRV-Tools-opt dependency if ENABLE_OPT
> * Support EXT_shader_quad_control
> * Add OpAssumeTrueKHR and OpExpectKHR
> * Support GL_EXT_maximal_reconvergence
> * Remove generation of deprecated Target.cmake files
> * Fix array size of gl_SampleMask and gl_SampleMaskIn
> * Support GL_ARB_texture_multisample_extension
> * Emit DebugTypePointer when non-semantic debug info is enabled
>
> Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
> ---
>  .../glslang/0001-generate-glslang-pkg-config.patch     | 10 +++++-----
>  .../{glslang_1.3.275.0.bb => glslang_1.3.280.0.bb}     |  2 +-
>  2 files changed, 6 insertions(+), 6 deletions(-)
>  rename meta/recipes-graphics/glslang/{glslang_1.3.275.0.bb => glslang_1.3.280.0.bb} (96%)
>
> diff --git a/meta/recipes-graphics/glslang/glslang/0001-generate-glslang-pkg-config.patch b/meta/recipes-graphics/glslang/glslang/0001-generate-glslang-pkg-config.patch
> index 316a57fa4a..e6bb6ec8e3 100644
> --- a/meta/recipes-graphics/glslang/glslang/0001-generate-glslang-pkg-config.patch
> +++ b/meta/recipes-graphics/glslang/glslang/0001-generate-glslang-pkg-config.patch
> @@ -1,4 +1,4 @@
> -From 4cede5edcff96134baf35953d58595c4aa5f1fc5 Mon Sep 17 00:00:00 2001
> +From fc33f1cf032a15c07044ef932bc991c346d62d62 Mon Sep 17 00:00:00 2001
>  From: Jose Quaresma <quaresma.jose@gmail.com>
>  Date: Sun, 7 Feb 2021 01:30:39 +0000
>  Subject: [PATCH] generate glslang pkg-config
> @@ -15,12 +15,12 @@ Signed-off-by: Jose Quaresma <quaresma.jose@gmail.com>
>   create mode 100644 glslang/glslang.pc.cmake.in
>
>  diff --git a/glslang/CMakeLists.txt b/glslang/CMakeLists.txt
> -index 37eecaad..6974935c 100644
> +index e4690f09..8e660bc5 100644
>  --- a/glslang/CMakeLists.txt
>  +++ b/glslang/CMakeLists.txt
> -@@ -251,6 +251,8 @@ if(PROJECT_IS_TOP_LEVEL)
> -         ")
> -         install(FILES "${CMAKE_CURRENT_BINARY_DIR}/glslangTargets.cmake" DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake)
> +@@ -233,6 +233,8 @@ if(GLSLANG_ENABLE_INSTALL)
> +         install(TARGETS MachineIndependent EXPORT glslang-targets)
> +         install(TARGETS GenericCodeGen EXPORT glslang-targets)
>       endif()
>  +    configure_file(${CMAKE_CURRENT_SOURCE_DIR}/glslang.pc.cmake.in ${CMAKE_CURRENT_BINARY_DIR}/pkgconfig/glslang.pc @ONLY)
>  +    install(FILES ${CMAKE_CURRENT_BINARY_DIR}/pkgconfig/glslang.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
> diff --git a/meta/recipes-graphics/glslang/glslang_1.3.275.0.bb b/meta/recipes-graphics/glslang/glslang_1.3.280.0.bb
> similarity index 96%
> rename from meta/recipes-graphics/glslang/glslang_1.3.275.0.bb
> rename to meta/recipes-graphics/glslang/glslang_1.3.280.0.bb
> index 2fd1e72a26..637082c719 100644
> --- a/meta/recipes-graphics/glslang/glslang_1.3.275.0.bb
> +++ b/meta/recipes-graphics/glslang/glslang_1.3.280.0.bb
> @@ -8,7 +8,7 @@ HOMEPAGE = "https://www.khronos.org/opengles/sdk/tools/Reference-Compiler"
>  LICENSE = "BSD-3-Clause & BSD-2-Clause & MIT & Apache-2.0 & GPL-3-with-bison-exception"
>  LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2a2b5acd7bc4844964cfda45fe807dc3"
>
> -SRCREV = "a91631b260cba3f22858d6c6827511e636c2458a"
> +SRCREV = "ee2f5d09eaf8f4e8d0d598bd2172fce290d4ca60"
>  SRC_URI = "git://github.com/KhronosGroup/glslang.git;protocol=https;branch=main \
>             file://0001-generate-glslang-pkg-config.patch \
>             "
> --
> 2.34.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#197496): https://lists.openembedded.org/g/openembedded-core/message/197496
> Mute This Topic: https://lists.openembedded.org/mt/105150498/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-graphics/glslang/glslang/0001-generate-glslang-pkg-config.patch b/meta/recipes-graphics/glslang/glslang/0001-generate-glslang-pkg-config.patch
index 316a57fa4a..e6bb6ec8e3 100644
--- a/meta/recipes-graphics/glslang/glslang/0001-generate-glslang-pkg-config.patch
+++ b/meta/recipes-graphics/glslang/glslang/0001-generate-glslang-pkg-config.patch
@@ -1,4 +1,4 @@ 
-From 4cede5edcff96134baf35953d58595c4aa5f1fc5 Mon Sep 17 00:00:00 2001
+From fc33f1cf032a15c07044ef932bc991c346d62d62 Mon Sep 17 00:00:00 2001
 From: Jose Quaresma <quaresma.jose@gmail.com>
 Date: Sun, 7 Feb 2021 01:30:39 +0000
 Subject: [PATCH] generate glslang pkg-config
@@ -15,12 +15,12 @@  Signed-off-by: Jose Quaresma <quaresma.jose@gmail.com>
  create mode 100644 glslang/glslang.pc.cmake.in
 
 diff --git a/glslang/CMakeLists.txt b/glslang/CMakeLists.txt
-index 37eecaad..6974935c 100644
+index e4690f09..8e660bc5 100644
 --- a/glslang/CMakeLists.txt
 +++ b/glslang/CMakeLists.txt
-@@ -251,6 +251,8 @@ if(PROJECT_IS_TOP_LEVEL)
-         ")
-         install(FILES "${CMAKE_CURRENT_BINARY_DIR}/glslangTargets.cmake" DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake)
+@@ -233,6 +233,8 @@ if(GLSLANG_ENABLE_INSTALL)
+         install(TARGETS MachineIndependent EXPORT glslang-targets)
+         install(TARGETS GenericCodeGen EXPORT glslang-targets)
      endif()
 +    configure_file(${CMAKE_CURRENT_SOURCE_DIR}/glslang.pc.cmake.in ${CMAKE_CURRENT_BINARY_DIR}/pkgconfig/glslang.pc @ONLY)
 +    install(FILES ${CMAKE_CURRENT_BINARY_DIR}/pkgconfig/glslang.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
diff --git a/meta/recipes-graphics/glslang/glslang_1.3.275.0.bb b/meta/recipes-graphics/glslang/glslang_1.3.280.0.bb
similarity index 96%
rename from meta/recipes-graphics/glslang/glslang_1.3.275.0.bb
rename to meta/recipes-graphics/glslang/glslang_1.3.280.0.bb
index 2fd1e72a26..637082c719 100644
--- a/meta/recipes-graphics/glslang/glslang_1.3.275.0.bb
+++ b/meta/recipes-graphics/glslang/glslang_1.3.280.0.bb
@@ -8,7 +8,7 @@  HOMEPAGE = "https://www.khronos.org/opengles/sdk/tools/Reference-Compiler"
 LICENSE = "BSD-3-Clause & BSD-2-Clause & MIT & Apache-2.0 & GPL-3-with-bison-exception"
 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2a2b5acd7bc4844964cfda45fe807dc3"
 
-SRCREV = "a91631b260cba3f22858d6c6827511e636c2458a"
+SRCREV = "ee2f5d09eaf8f4e8d0d598bd2172fce290d4ca60"
 SRC_URI = "git://github.com/KhronosGroup/glslang.git;protocol=https;branch=main \
            file://0001-generate-glslang-pkg-config.patch \
            "