diff mbox series

[27/34] python3-setuptools: upgrade 69.1.1 -> 69.2.0

Message ID 1711413292-3025-27-git-send-email-wangmy@fujitsu.com
State New
Headers show
Series [01/34] adwaita-icon-theme: upgrade 45.0 -> 46.0 | expand

Commit Message

Mingyu Wang (Fujitsu) March 26, 2024, 12:34 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

0001-conditionally-do-not-fetch-code-by-easy_install.patch
refreshed for 69.2.0

Changelog:
==========
-Explicitly use encoding="locale" for .pth files whenever possible, to reduce
 EncodingWarnings. This avoid errors with UTF-8
-Clarify some Package Discovery and Resource Access using pkg_resources methods
 return bytes, not str. Also return an empty bytes in EmptyProvider._get
-Return an empty list by default in pkg_resources.ResourceManager.cleanup_resources
-Made pkg_resoursces.NullProvider's has_metadata and metadata_isdir methods
 return actual booleans like all other Providers.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 ...01-conditionally-do-not-fetch-code-by-easy_install.patch | 6 +++---
 ...n3-setuptools_69.1.1.bb => python3-setuptools_69.2.0.bb} | 2 +-
 2 files changed, 4 insertions(+), 4 deletions(-)
 rename meta/recipes-devtools/python/{python3-setuptools_69.1.1.bb => python3-setuptools_69.2.0.bb} (94%)

Comments

Ross Burton April 23, 2024, 12:37 p.m. UTC | #1
Somehow, this distributes a copy of the build tree:

Changes to packages/aarch64-linux/python3-setuptools-native (sysroot):
  /usr/lib/python3.12/site-packages/build was added
  /usr/lib/python3.12/site-packages/build/lib was added
  /usr/lib/python3.12/site-packages/build/lib/_distutils_hack was added
  /usr/lib/python3.12/site-packages/build/lib/_distutils_hack/__init__.py was added
  /usr/lib/python3.12/site-packages/build/lib/_distutils_hack/override.py was added
  /usr/lib/python3.12/site-packages/build/lib/pkg_resources was added
  /usr/lib/python3.12/site-packages/build/lib/pkg_resources/extern was added
  /usr/lib/python3.12/site-packages/build/lib/pkg_resources/extern/__init__.py was added
  /usr/lib/python3.12/site-packages/build/lib/pkg_resources/__init__.py was added
  /usr/lib/python3.12/site-packages/build/lib/pkg_resources/_vendor was added
…

This is very broken and hopefully a newer release fixed it.

Ross
Ross Burton April 23, 2024, 3:39 p.m. UTC | #2
On 23 Apr 2024, at 13:37, Ross Burton via lists.openembedded.org <ross.burton=arm.com@lists.openembedded.org> wrote:
> 
> Somehow, this distributes a copy of the build tree:
> 
> Changes to packages/aarch64-linux/python3-setuptools-native (sysroot):
>  /usr/lib/python3.12/site-packages/build was added
>  /usr/lib/python3.12/site-packages/build/lib was added
>  /usr/lib/python3.12/site-packages/build/lib/_distutils_hack was added
>  /usr/lib/python3.12/site-packages/build/lib/_distutils_hack/__init__.py was added
>  /usr/lib/python3.12/site-packages/build/lib/_distutils_hack/override.py was added
>  /usr/lib/python3.12/site-packages/build/lib/pkg_resources was added
>  /usr/lib/python3.12/site-packages/build/lib/pkg_resources/extern was added
>  /usr/lib/python3.12/site-packages/build/lib/pkg_resources/extern/__init__.py was added
>  /usr/lib/python3.12/site-packages/build/lib/pkg_resources/__init__.py was added
>  /usr/lib/python3.12/site-packages/build/lib/pkg_resources/_vendor was added
> …
> 
> This is very broken and hopefully a newer release fixed it.

Oddly, if I rebuild the recipe this disappears.  This is _very_ odd but I can’t blame setuptools just yet.

Ross
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-setuptools/0001-conditionally-do-not-fetch-code-by-easy_install.patch b/meta/recipes-devtools/python/python3-setuptools/0001-conditionally-do-not-fetch-code-by-easy_install.patch
index 2a3c71fb62..e227c2889c 100644
--- a/meta/recipes-devtools/python/python3-setuptools/0001-conditionally-do-not-fetch-code-by-easy_install.patch
+++ b/meta/recipes-devtools/python/python3-setuptools/0001-conditionally-do-not-fetch-code-by-easy_install.patch
@@ -1,4 +1,4 @@ 
-From 40648dfa770f9f7b9b9efa501c9ef7af96be9f2d Mon Sep 17 00:00:00 2001
+From 80fe63816eb3bfd1f5b6d354e1f2442805cff4e0 Mon Sep 17 00:00:00 2001
 From: Hongxu Jia <hongxu.jia@windriver.com>
 Date: Tue, 17 Jul 2018 10:13:38 +0800
 Subject: [PATCH] conditionally do not fetch code by easy_install
@@ -14,10 +14,10 @@  Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
  1 file changed, 5 insertions(+)
 
 diff --git a/setuptools/command/easy_install.py b/setuptools/command/easy_install.py
-index 5d6fd5c..377e575 100644
+index 858fb20..62bd853 100644
 --- a/setuptools/command/easy_install.py
 +++ b/setuptools/command/easy_install.py
-@@ -676,6 +676,11 @@ class easy_install(Command):
+@@ -672,6 +672,11 @@ class easy_install(Command):
              os.path.exists(tmpdir) and _rmtree(tmpdir)
  
      def easy_install(self, spec, deps=False):
diff --git a/meta/recipes-devtools/python/python3-setuptools_69.1.1.bb b/meta/recipes-devtools/python/python3-setuptools_69.2.0.bb
similarity index 94%
rename from meta/recipes-devtools/python/python3-setuptools_69.1.1.bb
rename to meta/recipes-devtools/python/python3-setuptools_69.2.0.bb
index 77d4e0aa03..897398afc5 100644
--- a/meta/recipes-devtools/python/python3-setuptools_69.1.1.bb
+++ b/meta/recipes-devtools/python/python3-setuptools_69.2.0.bb
@@ -11,7 +11,7 @@  SRC_URI:append:class-native = " file://0001-conditionally-do-not-fetch-code-by-e
 SRC_URI += " \
             file://0001-_distutils-sysconfig.py-make-it-possible-to-substite.patch"
 
-SRC_URI[sha256sum] = "5c0806c7d9af348e6dd3777b4f4dbb42c7ad85b190104837488eab9a7c945cf8"
+SRC_URI[sha256sum] = "0ff4183f8f42cd8fa3acea16c45205521a4ef28f73c6391d8a25e92893134f2e"
 
 DEPENDS += "python3"