diff mbox series

[meta-python] python3-sdbus: add recipe

Message ID TY2PR02MB3678A5299B6D4775A7FF4FF181E1A@TY2PR02MB3678.apcprd02.prod.outlook.com
State Under Review
Headers show
Series [meta-python] python3-sdbus: add recipe | expand

Commit Message

Petr Gotthard Aug. 27, 2023, 3:13 p.m. UTC
sdbus is a modern Python library for D-Bus
https://github.com/python-sdbus/python-sdbus
https://python-sdbus.readthedocs.io/en/latest/index.html

Signed-off-by: Petr Gotthard <petr.gotthard@advantech.cz>
---
 .../recipes-devtools/python/python3-sdbus_0.11.0.bb   | 11 +++++++++++
 1 file changed, 11 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-sdbus_0.11.0.bb

-- 
2.34.1

Comments

Khem Raj Aug. 27, 2023, 3:42 p.m. UTC | #1
On Sun, Aug 27, 2023 at 8:13 AM Petr Gotthard
<petr.gotthard@advantech.cz> wrote:
>
> sdbus is a modern Python library for D-Bus
> https://github.com/python-sdbus/python-sdbus
> https://python-sdbus.readthedocs.io/en/latest/index.html
>
> Signed-off-by: Petr Gotthard <petr.gotthard@advantech.cz>
> ---
>  .../recipes-devtools/python/python3-sdbus_0.11.0.bb   | 11 +++++++++++
>  1 file changed, 11 insertions(+)
>  create mode 100644 meta-python/recipes-devtools/python/python3-sdbus_0.11.0.bb
>
> diff --git a/meta-python/recipes-devtools/python/python3-sdbus_0.11.0.bb b/meta-python/recipes-devtools/python/python3-sdbus_0.11.0.bb
> new file mode 100644
> index 000000000..84b4178f7
> --- /dev/null
> +++ b/meta-python/recipes-devtools/python/python3-sdbus_0.11.0.bb
> @@ -0,0 +1,11 @@
> +SUMMARY = "Modern Python library for D-Bus"
> +HOMEPAGE = "https://python-sdbus.readthedocs.io/en/latest/"
> +LICENSE = "LGPL-2.1-or-later"
> +LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e77986dc8e2ee22d44a7c863e96852ae"
> +
> +SRC_URI[md5sum] = "9cc6317acc14dbb89894719e06e4b0ff"
> +SRC_URI[sha256sum] = "f86fbadae54fea6441ec2f27dc29daf085269d66c5d9df1a4fbc9474a24b91d0"

Drop md5sum, its not needed anymore.

> +
> +DEPENDS += "systemd"
> +
> +inherit pypi setuptools3 pkgconfig

If it has hard dependency on systemd then please add

inherit features_check
REQUIRED_DISTRO_FEATURES.= "systemd"

> --
> 2.34.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#104626): https://lists.openembedded.org/g/openembedded-devel/message/104626
> Mute This Topic: https://lists.openembedded.org/mt/100991886/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-sdbus_0.11.0.bb b/meta-python/recipes-devtools/python/python3-sdbus_0.11.0.bb
new file mode 100644
index 000000000..84b4178f7
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-sdbus_0.11.0.bb
@@ -0,0 +1,11 @@ 
+SUMMARY = "Modern Python library for D-Bus"
+HOMEPAGE = "https://python-sdbus.readthedocs.io/en/latest/"
+LICENSE = "LGPL-2.1-or-later"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e77986dc8e2ee22d44a7c863e96852ae"
+
+SRC_URI[md5sum] = "9cc6317acc14dbb89894719e06e4b0ff"
+SRC_URI[sha256sum] = "f86fbadae54fea6441ec2f27dc29daf085269d66c5d9df1a4fbc9474a24b91d0"
+
+DEPENDS += "systemd"
+
+inherit pypi setuptools3 pkgconfig