[kirkstone,11/39] libldb: Fix installed-vs-shipped and rebuild error

Message ID 231fd21671eac6dd679cdbca6e58f552b28e39c1.1651346200.git.akuster808@gmail.com
State Accepted, archived
Headers show
Series [kirkstone,01/39] crash: Upgrade to 8.0.0 | expand

Commit Message

akuster808 April 30, 2022, 7:17 p.m. UTC
From: Robert Yang <liezhi.yang@windriver.com>

Fixed when multilib is disabled on intel-x86-64:
MULITLIBS = ""
$ bitbake sssd

ERROR: sssd-2.5.2-r0 do_package: QA Issue: sssd: Files/directories were installed but not shipped in any package:
/usr/lib/ldb
/usr/lib64/ldb/modules/ldb/memberof.so
Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install.
sssd: 2 installed and not shipped files. [installed-vs-shipped]

And also remove bin/ got get a clean rebuild, otherwise, the rebuild result may
be incorrect.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
(cherry picked from commit 5f6156c0ef842bd39e9eb1f7ce02eb7c7c961d3a)
Signed-off-by: Armin Kuster <akuster808@gmail.com>
---
 .../recipes-support/libldb/libldb_2.3.3.bb            | 11 +++++++++++
 1 file changed, 11 insertions(+)

Patch

diff --git a/meta-networking/recipes-support/libldb/libldb_2.3.3.bb b/meta-networking/recipes-support/libldb/libldb_2.3.3.bb
index c46a9784e3..6dd3ec3a9a 100644
--- a/meta-networking/recipes-support/libldb/libldb_2.3.3.bb
+++ b/meta-networking/recipes-support/libldb/libldb_2.3.3.bb
@@ -68,3 +68,14 @@  FILES:pyldb = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/* \
 FILES:pyldb-dbg = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/.debug \
                    ${libdir}/.debug/libpyldb-util.*.so.*"
 FILES:pyldb-dev = "${libdir}/libpyldb-util.*.so"
+
+# Prevent third_party/waf/waflib/Configure.py checking host's path which is
+# incorrect for cross building.
+export PREFIX = "/"
+export LIBDIR = "${libdir}"
+export BINDIR = "${bindir}"
+
+do_configure:prepend() {
+    # For a clean rebuild
+    rm -fr bin/
+}