diff mbox series

[meta-oe] libwebsockets: fix buildpath warnings

Message ID 20240516163058.465553-1-gerard.salvatella@siemens.com
State Accepted
Headers show
Series [meta-oe] libwebsockets: fix buildpath warnings | expand

Commit Message

G. Salvatella May 16, 2024, 4:30 p.m. UTC
From: Gerard Salvatella <gerard.salvatella@siemens.com>

In order to remove absolute paths from the cmake artifacts, paths from
the `$lib` folder should also be stripped off, otherwise internally
linked libraries (e.g. libz) may appear.
---
 .../recipes-connectivity/libwebsockets/libwebsockets_4.3.3.bb   | 2 ++
 1 file changed, 2 insertions(+)

Comments

Martin Jansa May 24, 2024, 6:22 p.m. UTC | #1
This breaks libcap dependency when libwebsocket is built with libcap in DEPENDS.

mosquitto fails with:
ninja: error: '/libcap.so', needed by 'src/mosquitto', missing and no
known rule to make it

because this change caused this diff:
+++ 4.3.3/image/usr/lib/cmake/libwebsockets/LibwebsocketsTargets.cmake
 2024-05-24 20:16:49.448901228 +0200
@@ -69,7 +69,7 @@

 set_target_properties(websockets_shared PROPERTIES
   INTERFACE_INCLUDE_DIRECTORIES "${_IMPORT_PREFIX}/include;"
-  INTERFACE_LINK_LIBRARIES
"ssl;crypto;ssl;crypto;/OE/lge/build/starfish/styhead/BUILD/work/o22-webosmllib32-linux-gnueabi/lib32-libwebsockets/4.3.3/lib32-recipe-sysroot/usr/lib/libcap.so;-lpthread"
+  INTERFACE_LINK_LIBRARIES "ssl;crypto;ssl;crypto;/libcap.so;-lpthread"
)

 if(CMAKE_VERSION VERSION_LESS 2.8.12)

I don't see libz there, but /libcap.so is surely wrong, removing the /
fixes the mosquitto build for me (I'm not using it, it just started to
fail in world builds now), will send the fix shortly.

On Thu, May 16, 2024 at 6:30 PM Gerard Salvatella via
lists.openembedded.org
<gerard.salvatella=siemens.com@lists.openembedded.org> wrote:
>
> From: Gerard Salvatella <gerard.salvatella@siemens.com>
>
> In order to remove absolute paths from the cmake artifacts, paths from
> the `$lib` folder should also be stripped off, otherwise internally
> linked libraries (e.g. libz) may appear.
> ---
>  .../recipes-connectivity/libwebsockets/libwebsockets_4.3.3.bb   | 2 ++
>  1 file changed, 2 insertions(+)
>
> diff --git a/meta-oe/recipes-connectivity/libwebsockets/libwebsockets_4.3.3.bb b/meta-oe/recipes-connectivity/libwebsockets/libwebsockets_4.3.3.bb
> index 4518e2faa..8f8b70421 100644
> --- a/meta-oe/recipes-connectivity/libwebsockets/libwebsockets_4.3.3.bb
> +++ b/meta-oe/recipes-connectivity/libwebsockets/libwebsockets_4.3.3.bb
> @@ -42,6 +42,8 @@ do_install:append() {
>      sed -i -e 's|${STAGING_LIBDIR}/libuv.so|uv|g' ${D}${libdir}/cmake/libwebsockets/LibwebsocketsTargets.cmake
>      sed -i -e 's|${STAGING_INCDIR}||g' ${D}${libdir}/cmake/libwebsockets/LibwebsocketsTargets.cmake \
>                                         ${D}${libdir}/cmake/libwebsockets/libwebsockets-config.cmake
> +    sed -i -e 's|${STAGING_LIBDIR}||g' ${D}${libdir}/cmake/libwebsockets/LibwebsocketsTargets.cmake \
> +                                       ${D}${libdir}/cmake/libwebsockets/libwebsockets-config.cmake
>  }
>
>  PACKAGES =+ "${PN}-testapps ${PN}-evlib-event ${PN}-evlib-uv ${PN}-evlib-ev ${PN}-evlib-sd"
> --
> 2.44.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#110416): https://lists.openembedded.org/g/openembedded-devel/message/110416
> Mute This Topic: https://lists.openembedded.org/mt/106138059/3617156
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [martin.jansa@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-oe/recipes-connectivity/libwebsockets/libwebsockets_4.3.3.bb b/meta-oe/recipes-connectivity/libwebsockets/libwebsockets_4.3.3.bb
index 4518e2faa..8f8b70421 100644
--- a/meta-oe/recipes-connectivity/libwebsockets/libwebsockets_4.3.3.bb
+++ b/meta-oe/recipes-connectivity/libwebsockets/libwebsockets_4.3.3.bb
@@ -42,6 +42,8 @@  do_install:append() {
     sed -i -e 's|${STAGING_LIBDIR}/libuv.so|uv|g' ${D}${libdir}/cmake/libwebsockets/LibwebsocketsTargets.cmake
     sed -i -e 's|${STAGING_INCDIR}||g' ${D}${libdir}/cmake/libwebsockets/LibwebsocketsTargets.cmake \
                                        ${D}${libdir}/cmake/libwebsockets/libwebsockets-config.cmake
+    sed -i -e 's|${STAGING_LIBDIR}||g' ${D}${libdir}/cmake/libwebsockets/LibwebsocketsTargets.cmake \
+                                       ${D}${libdir}/cmake/libwebsockets/libwebsockets-config.cmake
 }
 
 PACKAGES =+ "${PN}-testapps ${PN}-evlib-event ${PN}-evlib-uv ${PN}-evlib-ev ${PN}-evlib-sd"