diff mbox series

opentelemetry-cpp: add opentelemtry recipe

Message ID 20240515052002.3843823-1-abhilash.kollam@gmail.com
State New
Headers show
Series opentelemetry-cpp: add opentelemtry recipe | expand

Commit Message

Abhilash Kollam May 15, 2024, 5:20 a.m. UTC
An Observability framework to create and manage telemetry data such as
traces, metrics, and logs

Signed-off-by: Abhilash Raju <abhilash.kollam@gmail.com>
---
 .../opentelemetry/opentelemetry-cpp_1.15.0.bb   | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)
 create mode 100644 meta-oe/recipes-support/opentelemetry/opentelemetry-cpp_1.15.0.bb

Comments

Khem Raj May 15, 2024, 5:28 a.m. UTC | #1
On Tue, May 14, 2024 at 10:20 PM Abhilash Raju via
lists.openembedded.org
<abhilash.kollam=gmail.com@lists.openembedded.org> wrote:
>
> An Observability framework to create and manage telemetry data such as
> traces, metrics, and logs
>

Thanks for your patch, I have a few comments below.

> Signed-off-by: Abhilash Raju <abhilash.kollam@gmail.com>
> ---
>  .../opentelemetry/opentelemetry-cpp_1.15.0.bb   | 17 +++++++++++++++++
>  1 file changed, 17 insertions(+)
>  create mode 100644 meta-oe/recipes-support/opentelemetry/opentelemetry-cpp_1.15.0.bb
>
> diff --git a/meta-oe/recipes-support/opentelemetry/opentelemetry-cpp_1.15.0.bb b/meta-oe/recipes-support/opentelemetry/opentelemetry-cpp_1.15.0.bb
> new file mode 100644
> index 000000000..85df5be82
> --- /dev/null
> +++ b/meta-oe/recipes-support/opentelemetry/opentelemetry-cpp_1.15.0.bb
> @@ -0,0 +1,17 @@
> +SUMMARY = "Open Telemetry Library"
> +DESCRIPTION = "An Observability framework to create and manage telemetry data \
> +such as traces, metrics, and logs."
> +HOMEPAGE = "https://github.com/open-telemetry/opentelemetry-cpp"
> +SECTION = "libs"
> +LICENSE = "Apache-2.0"
> +LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
> +
> +DEPENDS = "nlohmann-json"
> +
> +SRC_URI = "https://github.com/open-telemetry/opentelemetry-cpp/archive/refs/tags/v${PV}.tar.gz"

github archives can be regenerated and hence we do not use them unless
the release archives are created explicitly. So please convert
it into a git fetcher based SRC_URI pointing SRCREV at 1.15.0  SHA

> +SRC_URI[sha256sum] = "69b0fef380658e15be9d817bfcb32e3f5de96da652bcdce77b4e750ed8beddee"
> +
> +S = "${WORKDIR}/opentelemetry-cpp-${PV}"
> +
> +inherit cmake pkgconfig lib_package
> +EXTRA_OECMAKE = "-DOPENTELEMETRY_INSTALL=ON -DBUILD_PACKAGE=OFF -DWITH_OTLP_API=ON -DWITH_OTLP_GRPC=OFF -DWITH_OTLP_HTTP=OFF -DWITH_PROMETHEUS=OFF -DWITH_BENCHMARK=OFF -DBUILD_TESTING=OFF"

All these look good candidates for PACKAGECONFIG elements, so please
convert them

> --
> 2.40.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#110401): https://lists.openembedded.org/g/openembedded-devel/message/110401
> Mute This Topic: https://lists.openembedded.org/mt/106109161/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Anuj Mittal May 15, 2024, 8:04 a.m. UTC | #2
On Wed, 2024-05-15 at 00:20 -0500, Abhilash Raju wrote:
> An Observability framework to create and manage telemetry data such
> as
> traces, metrics, and logs
> 
> Signed-off-by: Abhilash Raju <abhilash.kollam@gmail.com>
> ---
>  .../opentelemetry/opentelemetry-cpp_1.15.0.bb   | 17
> +++++++++++++++++
>  1 file changed, 17 insertions(+)
>  create mode 100644 meta-oe/recipes-
> support/opentelemetry/opentelemetry-cpp_1.15.0.bb
> 
> diff --git a/meta-oe/recipes-support/opentelemetry/opentelemetry-
> cpp_1.15.0.bb b/meta-oe/recipes-support/opentelemetry/opentelemetry-
> cpp_1.15.0.bb
> new file mode 100644
> index 000000000..85df5be82
> --- /dev/null
> +++ b/meta-oe/recipes-support/opentelemetry/opentelemetry-
> cpp_1.15.0.bb
> @@ -0,0 +1,17 @@
> +SUMMARY = "Open Telemetry Library"
> +DESCRIPTION = "An Observability framework to create and manage
> telemetry data \
> +such as traces, metrics, and logs."
> +HOMEPAGE = "https://github.com/open-telemetry/opentelemetry-cpp"
> +SECTION = "libs"
> +LICENSE = "Apache-2.0"
> +LIC_FILES_CHKSUM =
> "file://${S}/LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"

${S} shouldn't be needed here.

> +
> +DEPENDS = "nlohmann-json"
> +
> +SRC_URI =
> "https://github.com/open-telemetry/opentelemetry-cpp/archive/refs/tag
> s/v${PV}.tar.gz"
> +SRC_URI[sha256sum] =
> "69b0fef380658e15be9d817bfcb32e3f5de96da652bcdce77b4e750ed8beddee"
> +
> +S = "${WORKDIR}/opentelemetry-cpp-${PV}"

This is default so shouldn't be needed.

https://git.yoctoproject.org/poky/tree/meta/conf/bitbake.conf#n411
Abhilash Kollam May 29, 2024, 9:21 a.m. UTC | #3
Done.

On Wed, May 15, 2024 at 1:34 PM Mittal, Anuj <anuj.mittal@intel.com> wrote:

> On Wed, 2024-05-15 at 00:20 -0500, Abhilash Raju wrote:
> > An Observability framework to create and manage telemetry data such
> > as
> > traces, metrics, and logs
> >
> > Signed-off-by: Abhilash Raju <abhilash.kollam@gmail.com>
> > ---
> >  .../opentelemetry/opentelemetry-cpp_1.15.0.bb   | 17
> > +++++++++++++++++
> >  1 file changed, 17 insertions(+)
> >  create mode 100644 meta-oe/recipes-
> > support/opentelemetry/opentelemetry-cpp_1.15.0.bb
> >
> > diff --git a/meta-oe/recipes-support/opentelemetry/opentelemetry-
> > cpp_1.15.0.bb b/meta-oe/recipes-support/opentelemetry/opentelemetry-
> > cpp_1.15.0.bb
> > new file mode 100644
> > index 000000000..85df5be82
> > --- /dev/null
> > +++ b/meta-oe/recipes-support/opentelemetry/opentelemetry-
> > cpp_1.15.0.bb
> > @@ -0,0 +1,17 @@
> > +SUMMARY = "Open Telemetry Library"
> > +DESCRIPTION = "An Observability framework to create and manage
> > telemetry data \
> > +such as traces, metrics, and logs."
> > +HOMEPAGE = "https://github.com/open-telemetry/opentelemetry-cpp"
> > +SECTION = "libs"
> > +LICENSE = "Apache-2.0"
> > +LIC_FILES_CHKSUM =
> > "file://${S}/LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
>
> ${S} shouldn't be needed here.
>
> > +
> > +DEPENDS = "nlohmann-json"
> > +
> > +SRC_URI =
> > "https://github.com/open-telemetry/opentelemetry-cpp/archive/refs/tag
> > s/v${PV}.tar.gz"
> > +SRC_URI[sha256sum] =
> > "69b0fef380658e15be9d817bfcb32e3f5de96da652bcdce77b4e750ed8beddee"
> > +
> > +S = "${WORKDIR}/opentelemetry-cpp-${PV}"
>
> This is default so shouldn't be needed.
>
> https://git.yoctoproject.org/poky/tree/meta/conf/bitbake.conf#n411
>
diff mbox series

Patch

diff --git a/meta-oe/recipes-support/opentelemetry/opentelemetry-cpp_1.15.0.bb b/meta-oe/recipes-support/opentelemetry/opentelemetry-cpp_1.15.0.bb
new file mode 100644
index 000000000..85df5be82
--- /dev/null
+++ b/meta-oe/recipes-support/opentelemetry/opentelemetry-cpp_1.15.0.bb
@@ -0,0 +1,17 @@ 
+SUMMARY = "Open Telemetry Library"
+DESCRIPTION = "An Observability framework to create and manage telemetry data \
+such as traces, metrics, and logs."
+HOMEPAGE = "https://github.com/open-telemetry/opentelemetry-cpp"
+SECTION = "libs"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+DEPENDS = "nlohmann-json"
+
+SRC_URI = "https://github.com/open-telemetry/opentelemetry-cpp/archive/refs/tags/v${PV}.tar.gz"
+SRC_URI[sha256sum] = "69b0fef380658e15be9d817bfcb32e3f5de96da652bcdce77b4e750ed8beddee"
+
+S = "${WORKDIR}/opentelemetry-cpp-${PV}"
+
+inherit cmake pkgconfig lib_package
+EXTRA_OECMAKE = "-DOPENTELEMETRY_INSTALL=ON -DBUILD_PACKAGE=OFF -DWITH_OTLP_API=ON -DWITH_OTLP_GRPC=OFF -DWITH_OTLP_HTTP=OFF -DWITH_PROMETHEUS=OFF -DWITH_BENCHMARK=OFF -DBUILD_TESTING=OFF"