diff mbox series

[meta-oe,1/3] glib-testing: add recipe

Message ID 20240512091524.90050-1-f_l_k@t-online.de
State Accepted
Headers show
Series [meta-oe,1/3] glib-testing: add recipe | expand

Commit Message

Markus Volk May 12, 2024, 9:15 a.m. UTC
glib-testing is a build dependency for malcontent, where building the tests cant be disabled.
We can only disable the run of installed tests in malcontent.

Normally glib-testing gets included as a subproject wrap which is inappropriate for
yocto/oe. Thus we need to provide a recipe for it.

Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 .../recipes-core/glib-2.0/glib-testing_0.1.1.bb    | 14 ++++++++++++++
 1 file changed, 14 insertions(+)
 create mode 100644 meta-oe/recipes-core/glib-2.0/glib-testing_0.1.1.bb

Comments

Khem Raj May 12, 2024, 6:04 p.m. UTC | #1
fails to build

https://errors.yoctoproject.org/Errors/Details/767428/

On Sun, May 12, 2024 at 2:15 AM Markus Volk via lists.openembedded.org
<f_l_k=t-online.de@lists.openembedded.org> wrote:
>
> glib-testing is a build dependency for malcontent, where building the tests cant be disabled.
> We can only disable the run of installed tests in malcontent.
>
> Normally glib-testing gets included as a subproject wrap which is inappropriate for
> yocto/oe. Thus we need to provide a recipe for it.
>
> Signed-off-by: Markus Volk <f_l_k@t-online.de>
> ---
>  .../recipes-core/glib-2.0/glib-testing_0.1.1.bb    | 14 ++++++++++++++
>  1 file changed, 14 insertions(+)
>  create mode 100644 meta-oe/recipes-core/glib-2.0/glib-testing_0.1.1.bb
>
> diff --git a/meta-oe/recipes-core/glib-2.0/glib-testing_0.1.1.bb b/meta-oe/recipes-core/glib-2.0/glib-testing_0.1.1.bb
> new file mode 100644
> index 000000000..0f6ea7643
> --- /dev/null
> +++ b/meta-oe/recipes-core/glib-2.0/glib-testing_0.1.1.bb
> @@ -0,0 +1,14 @@
> +SUMMARY = "libglib-testing provides test harnesses and mock classes to complement GLib classes"
> +HOMEPAGE = "https://gitlab.gnome.org/pwithnall/libglib-testing"
> +LICENSE = "LGPL-2.1-only"
> +LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
> +
> +SRC_URI = "git://gitlab.gnome.org/pwithnall/libglib-testing.git;protocol=https;branch=main"
> +
> +PV = "0.1.1"
> +S = "${WORKDIR}/git"
> +SRCREV = "e326f73a7139c5e54fcf926896ae6e4cc899a1a7"
> +
> +inherit  meson pkgconfig
> +
> +DEPENDS = "glib-2.0 gtk-doc-native"
> --
> 2.44.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#110315): https://lists.openembedded.org/g/openembedded-devel/message/110315
> Mute This Topic: https://lists.openembedded.org/mt/106052376/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-oe/recipes-core/glib-2.0/glib-testing_0.1.1.bb b/meta-oe/recipes-core/glib-2.0/glib-testing_0.1.1.bb
new file mode 100644
index 000000000..0f6ea7643
--- /dev/null
+++ b/meta-oe/recipes-core/glib-2.0/glib-testing_0.1.1.bb
@@ -0,0 +1,14 @@ 
+SUMMARY = "libglib-testing provides test harnesses and mock classes to complement GLib classes"
+HOMEPAGE = "https://gitlab.gnome.org/pwithnall/libglib-testing"
+LICENSE = "LGPL-2.1-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
+
+SRC_URI = "git://gitlab.gnome.org/pwithnall/libglib-testing.git;protocol=https;branch=main"
+
+PV = "0.1.1"
+S = "${WORKDIR}/git"
+SRCREV = "e326f73a7139c5e54fcf926896ae6e4cc899a1a7"
+
+inherit  meson pkgconfig
+
+DEPENDS = "glib-2.0 gtk-doc-native"