diff mbox series

[meta-python] python3-pyhamcrest: cleanup RDEPENDS and correct build backend

Message ID 20240427182959.1491435-1-gudnimar@noxmedical.com
State Accepted
Headers show
Series [meta-python] python3-pyhamcrest: cleanup RDEPENDS and correct build backend | expand

Commit Message

Guðni Már Gilbert April 27, 2024, 6:29 p.m. UTC
- build backend is hatchling.build
- python3-six is not a runtime dependency, it's not imported anywhere in the source
- add python3-asyncio to RDEPENDS

Signed-off-by: Guðni Már Gilbert <gudnimar@noxmedical.com>
---
 .../recipes-devtools/python/python3-pyhamcrest_2.1.0.bb       | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pyhamcrest_2.1.0.bb b/meta-python/recipes-devtools/python/python3-pyhamcrest_2.1.0.bb
index eaa24eefe..dcc9ebfa9 100644
--- a/meta-python/recipes-devtools/python/python3-pyhamcrest_2.1.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pyhamcrest_2.1.0.bb
@@ -5,7 +5,7 @@  LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=79391bf1501c898472d043f36e960612"
 
 SRC_URI[sha256sum] = "c6acbec0923d0cb7e72c22af1926f3e7c97b8e8d69fc7498eabacaf7c975bd9c"
 
-inherit pypi python_setuptools_build_meta
+inherit pypi python_hatchling
 
 DEPENDS += "python3-hatch-vcs-native"
 
@@ -13,6 +13,6 @@  UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/PyHamcrest/"
 UPSTREAM_CHECK_REGEX = "/PyHamcrest/(?P<pver>(\d+[\.\-_]*)+)"
 
 RDEPENDS:${PN} += " \
-    python3-six \
+    python3-asyncio \
     python3-numbers \
 "