diff mbox series

[meta-python,V2] python3-incremental: cleanup RDEPENDS and use python_setuptools_build_meta

Message ID 20240423063812.4192-1-gudnimar@noxmedical.com
State Accepted
Headers show
Series [meta-python,V2] python3-incremental: cleanup RDEPENDS and use python_setuptools_build_meta | expand

Commit Message

Guðni Már Gilbert April 23, 2024, 6:38 a.m. UTC
Signed-off-by: Guðni Már Gilbert <gudnimar@noxmedical.com>
---
 .../recipes-devtools/python/python3-incremental_22.10.0.bb  | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-incremental_22.10.0.bb b/meta-python/recipes-devtools/python/python3-incremental_22.10.0.bb
index 3d93cc05e..503ef35a9 100644
--- a/meta-python/recipes-devtools/python/python3-incremental_22.10.0.bb
+++ b/meta-python/recipes-devtools/python/python3-incremental_22.10.0.bb
@@ -5,15 +5,15 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=6ca9b07f08e2c72d48c74d363d1e0e15"
 
 SRC_URI[sha256sum] = "912feeb5e0f7e0188e6f42241d2f450002e11bbc0937c65865045854c24c0bd0"
 
-inherit pypi setuptools3
+inherit pypi python_setuptools_build_meta
 
 RDEPENDS:${PN} += " \
-    python3-twisted \
+    python3-twisted-core \
     python3-click \
 "
 
 # -native is needed to build python[3]-twisted, however, we need to take steps to
 # prevent a circular dependency. The build apparently does not use the part of
 # python-incremental which uses python-twisted, so this hack is OK.
-RDEPENDS:python3-incremental-native:remove = "python3-twisted-native"
+RDEPENDS:python3-incremental-native:remove = "python3-twisted-core-native"
 BBCLASSEXTEND = "native"