diff mbox series

[meta-python] python3-django: upgrade 4.2.10 -> 4.2.11

Message ID 20240327103811.4078264-1-fathi.boudra@linaro.org
State Accepted
Headers show
Series [meta-python] python3-django: upgrade 4.2.10 -> 4.2.11 | expand

Commit Message

Fathi Boudra March 27, 2024, 10:38 a.m. UTC
CVE-2024-27351: Potential regular expression denial-of-service in
django.utils.text.Truncator.words()

Fixed a regression in Django 4.2.10 where intcomma template filter could
return a leading comma for string representation of floats.
https://code.djangoproject.com/ticket/35172

Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
---
 .../{python3-django_4.2.10.bb => python3-django_4.2.11.bb}    | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-django_4.2.10.bb => python3-django_4.2.11.bb} (60%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-django_4.2.10.bb b/meta-python/recipes-devtools/python/python3-django_4.2.11.bb
similarity index 60%
rename from meta-python/recipes-devtools/python/python3-django_4.2.10.bb
rename to meta-python/recipes-devtools/python/python3-django_4.2.11.bb
index c78c8aab5e..0642b7e7c3 100644
--- a/meta-python/recipes-devtools/python/python3-django_4.2.10.bb
+++ b/meta-python/recipes-devtools/python/python3-django_4.2.11.bb
@@ -1,7 +1,7 @@ 
 require python-django.inc
 inherit setuptools3
 
-SRC_URI[sha256sum] = "b1260ed381b10a11753c73444408e19869f3241fc45c985cd55a30177c789d13"
+SRC_URI[sha256sum] = "6e6ff3db2d8dd0c986b4eec8554c8e4f919b5c1ff62a5b4390c17aff2ed6e5c4"
 
 RDEPENDS:${PN} += "\
     python3-sqlparse \
@@ -10,5 +10,5 @@  RDEPENDS:${PN} += "\
 
 # Set DEFAULT_PREFERENCE so that the LTS version of django is built by
 # default. To build the 4.x branch, 
-# PREFERRED_VERSION_python3-django = "4.0.2" can be added to local.conf
+# PREFERRED_VERSION_python3-django = "4.2.11" can be added to local.conf
 DEFAULT_PREFERENCE = "-1"