diff mbox series

Packages depends on libadwaita should require distro feature opengl

Message ID 20240320025845.1643620-1-kai.kang@windriver.com
State New
Headers show
Series Packages depends on libadwaita should require distro feature opengl | expand

Commit Message

Kai March 20, 2024, 2:58 a.m. UTC
From: Kai Kang <kai.kang@windriver.com>

libadwaita requires distro feature 'opengl', so packages depends on it
either directly or indirectly should require distro feature 'opengl'
too.

Signed-off-by: Kai Kang <kai.kang@windriver.com>
---
 .../network-manager-applet/network-manager-applet_1.36.0.bb    | 1 +
 meta-gnome/recipes-gnome/gfbgraph/gfbgraph_0.2.5.bb            | 2 +-
 meta-gnome/recipes-gnome/ghex/ghex_45.1.bb                     | 2 ++
 meta-gnome/recipes-gnome/gnome-console/gnome-console_45.0.bb   | 1 +
 .../gnome-online-accounts/gnome-online-accounts_3.48.0.bb      | 1 +
 meta-gnome/recipes-gnome/libgdata/libgdata_0.18.1.bb           | 1 +
 meta-gnome/recipes-gnome/rest/rest_0.9.1.bb                    | 3 ++-
 meta-gnome/recipes-gnome/zenity/zenity_4.0.1.bb                | 1 +
 8 files changed, 10 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/meta-gnome/recipes-connectivity/network-manager-applet/network-manager-applet_1.36.0.bb b/meta-gnome/recipes-connectivity/network-manager-applet/network-manager-applet_1.36.0.bb
index 5f1f05cb2c..10e514775a 100644
--- a/meta-gnome/recipes-connectivity/network-manager-applet/network-manager-applet_1.36.0.bb
+++ b/meta-gnome/recipes-connectivity/network-manager-applet/network-manager-applet_1.36.0.bb
@@ -7,6 +7,7 @@  DEPENDS = "gtk+3 libnma libnotify libsecret libgudev networkmanager iso-codes ns
 inherit features_check gnomebase gsettings gtk-icon-cache gettext pkgconfig
 
 ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
+REQUIRED_DISTRO_FEATURES = "opengl"
 
 SRC_URI:append:libc-musl = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-lld', ' file://0001-linker-scripts-Do-not-export-_IO_stdin_used.patch', '', d)}"
 
diff --git a/meta-gnome/recipes-gnome/gfbgraph/gfbgraph_0.2.5.bb b/meta-gnome/recipes-gnome/gfbgraph/gfbgraph_0.2.5.bb
index e9ee434add..9b1a02bb09 100644
--- a/meta-gnome/recipes-gnome/gfbgraph/gfbgraph_0.2.5.bb
+++ b/meta-gnome/recipes-gnome/gfbgraph/gfbgraph_0.2.5.bb
@@ -14,7 +14,7 @@  GNOMEBASEBUILDCLASS = "autotools"
 inherit gnomebase gtk-doc gobject-introspection pkgconfig features_check
 
 # for gnome-online-accounts
-REQUIRED_DISTRO_FEATURES = "x11"
+REQUIRED_DISTRO_FEATURES = "x11 opengl"
 
 #SRC_URI += " file://0001-Update-rest-requirement-to-rest-1.0.patch"
 SRC_URI[archive.sha256sum] = "9cb381b3f78ba1136df97af3f06e3b11dcc2ab339ac08f74eda0f8057d6603e3"
diff --git a/meta-gnome/recipes-gnome/ghex/ghex_45.1.bb b/meta-gnome/recipes-gnome/ghex/ghex_45.1.bb
index 2b6adaf91c..5901e3c093 100644
--- a/meta-gnome/recipes-gnome/ghex/ghex_45.1.bb
+++ b/meta-gnome/recipes-gnome/ghex/ghex_45.1.bb
@@ -17,4 +17,6 @@  inherit gnomebase gsettings gtk-icon-cache gnome-help gettext gobject-introspect
 
 SRC_URI[archive.sha256sum] = "fb2b0823cd16249edbeaee8302f9bd5005e0150368b35f1e47c26680cacac2fa"
 
+REQUIRED_DISTRO_FEATURES = "opengl"
+
 FILES:${PN} += "${libdir} ${datadir}/metainfo"
diff --git a/meta-gnome/recipes-gnome/gnome-console/gnome-console_45.0.bb b/meta-gnome/recipes-gnome/gnome-console/gnome-console_45.0.bb
index 9669e337a8..d03b5fe04d 100644
--- a/meta-gnome/recipes-gnome/gnome-console/gnome-console_45.0.bb
+++ b/meta-gnome/recipes-gnome/gnome-console/gnome-console_45.0.bb
@@ -4,6 +4,7 @@  LIC_FILES_CHKSUM = "file://COPYING;md5=8f0e2cd40e05189ec81232da84bd6e1a"
 
 GTKIC_VERSION = "4"
 inherit gnomebase gsettings pkgconfig gtk-icon-cache
+REQUIRED_DISTRO_FEATURES = "opengl"
 
 DEPENDS = " \
     desktop-file-utils-native \
diff --git a/meta-gnome/recipes-gnome/gnome-online-accounts/gnome-online-accounts_3.48.0.bb b/meta-gnome/recipes-gnome/gnome-online-accounts/gnome-online-accounts_3.48.0.bb
index 47b234e235..5742e8e964 100644
--- a/meta-gnome/recipes-gnome/gnome-online-accounts/gnome-online-accounts_3.48.0.bb
+++ b/meta-gnome/recipes-gnome/gnome-online-accounts/gnome-online-accounts_3.48.0.bb
@@ -4,6 +4,7 @@  LIC_FILES_CHKSUM = "file://COPYING;md5=34c88b124db5fb2762c1676be7dadd36"
 
 
 inherit gnomebase gsettings gobject-introspection gtk-icon-cache vala features_check
+REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('PACKAGECONFIG', 'goabackend', 'opengl', '', d)}"
 
 DEPENDS = "gdk-pixbuf dbus glib-2.0"
 
diff --git a/meta-gnome/recipes-gnome/libgdata/libgdata_0.18.1.bb b/meta-gnome/recipes-gnome/libgdata/libgdata_0.18.1.bb
index 15e3d889f5..a65fc61feb 100644
--- a/meta-gnome/recipes-gnome/libgdata/libgdata_0.18.1.bb
+++ b/meta-gnome/recipes-gnome/libgdata/libgdata_0.18.1.bb
@@ -14,6 +14,7 @@  GTKDOC_MESON_OPTION = "gtk_doc"
 inherit gnomebase pkgconfig gettext gtk-doc vala gobject-introspection manpages features_check
 
 ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
+REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('PACKAGECONFIG', 'goa', 'opengl', '', d)}"
 
 do_compile:prepend() {
     export GIR_EXTRA_LIBS_PATH="${B}/gdata/.libs"
diff --git a/meta-gnome/recipes-gnome/rest/rest_0.9.1.bb b/meta-gnome/recipes-gnome/rest/rest_0.9.1.bb
index 738b07e8cd..3b22fdfea2 100644
--- a/meta-gnome/recipes-gnome/rest/rest_0.9.1.bb
+++ b/meta-gnome/recipes-gnome/rest/rest_0.9.1.bb
@@ -14,7 +14,8 @@  DEPENDS = " \
     libxml2-native \
 "
 
-inherit gnomebase gobject-introspection vala pkgconfig gi-docgen
+inherit gnomebase gobject-introspection vala pkgconfig gi-docgen features_check
+REQUIRED_DISTRO_FEATURES = "opengl"
 
 PACKAGECONFIG ?= ""
 PACKAGECONFIG[examples] = "-Dexamples=true,-Dexamples=false"
diff --git a/meta-gnome/recipes-gnome/zenity/zenity_4.0.1.bb b/meta-gnome/recipes-gnome/zenity/zenity_4.0.1.bb
index 50e5eaa79f..88b4b5c86c 100644
--- a/meta-gnome/recipes-gnome/zenity/zenity_4.0.1.bb
+++ b/meta-gnome/recipes-gnome/zenity/zenity_4.0.1.bb
@@ -15,6 +15,7 @@  DEPENDS = " \
 "
 
 ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
+REQUIRED_DISTRO_FEATURES = "opengl"
 GTKIC_VERSION = "4"
 
 SRC_URI[archive.sha256sum] = "0c2f537813b10f728470d9d05d6c95713db2512f9c95096e1e85b1a6739605e6"