diff mbox series

[meta-python] python3-pydantic-core: just set PYPI_PACKAGE

Message ID 20240315114159.1063479-1-ross.burton@arm.com
State Accepted
Headers show
Series [meta-python] python3-pydantic-core: just set PYPI_PACKAGE | expand

Commit Message

Ross Burton March 15, 2024, 11:41 a.m. UTC
From: Ross Burton <ross.burton@arm.com>

There's no need to set PYPI_ARCHIVE_NAME and S explicitly if PYPI_PACKAGE
is set correctly.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 .../recipes-devtools/python/python3-pydantic-core_2.16.3.bb   | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)

Comments

Khem Raj March 17, 2024, 8:18 p.m. UTC | #1
On Fri, 15 Mar 2024 11:41:59 +0000, ross.burton@arm.com wrote:
> There's no need to set PYPI_ARCHIVE_NAME and S explicitly if PYPI_PACKAGE
> is set correctly.
> 
> 

Applied, thanks!

[1/1] python3-pydantic-core: just set PYPI_PACKAGE
      commit: d52c3b94068f660b729361bb969129d50eaf81a6

Best regards,
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pydantic-core_2.16.3.bb b/meta-python/recipes-devtools/python/python3-pydantic-core_2.16.3.bb
index b26478451a..2086091d63 100644
--- a/meta-python/recipes-devtools/python/python3-pydantic-core_2.16.3.bb
+++ b/meta-python/recipes-devtools/python/python3-pydantic-core_2.16.3.bb
@@ -17,9 +17,7 @@  require ${BPN}-crates.inc
 
 inherit pypi cargo-update-recipe-crates python_maturin
 
-S = "${WORKDIR}/pydantic_core-${PV}"
-
-PYPI_ARCHIVE_NAME = "pydantic_core-${PV}.${PYPI_PACKAGE_EXT}"
+PYPI_PACKAGE = "pydantic_core"
 
 RDEPENDS:${PN} += "python3-typing-extensions"