diff mbox series

[meta-python,1/3] python3-pytest-localserver: added recipe which is also include ptest

Message ID 20240308055136.81476-1-alperyasinak1@gmail.com
State Accepted
Headers show
Series [meta-python,1/3] python3-pytest-localserver: added recipe which is also include ptest | expand

Commit Message

Alper Ak March 8, 2024, 5:51 a.m. UTC
pytest-localserver is a plugin for the pytest testing framework which enables you to test server connections locally.

* Tested on qemux86-64 and qemuarm64

* Add ptest into PTESTS_SLOW_META_PYTHON

Ptest result:
==============
qemux86-64:

Testsuite summary
TOTAL: 55
PASS: 54
SKIP: 1
XFAIL: 0
FAIL: 0
XPASS: 0
ERROR: 0
DURATION: 44
END: /usr/lib/python3-pytest-localserver/ptest
2024-03-07T20:33
STOP: ptest-runner
TOTAL: 1 FAIL: 0

qemuarm64:

Testsuite summary
TOTAL: 55
PASS: 54
SKIP: 1
XFAIL: 0
FAIL: 0
XPASS: 0
ERROR: 0
DURATION: 38
END: /usr/lib/python3-pytest-localserver/ptest
2024-03-07T20:41
STOP: ptest-runner
TOTAL: 1 FAIL: 0

Signed-off-by: alperak <alperyasinak1@gmail.com>
---
 .../ptest-packagelists-meta-python.inc        |  1 +
 .../python3-pytest-localserver/run-ptest      |  3 ++
 .../python3-pytest-localserver_0.8.1.bb       | 29 +++++++++++++++++++
 3 files changed, 33 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-pytest-localserver/run-ptest
 create mode 100644 meta-python/recipes-devtools/python/python3-pytest-localserver_0.8.1.bb
diff mbox series

Patch

diff --git a/meta-python/conf/include/ptest-packagelists-meta-python.inc b/meta-python/conf/include/ptest-packagelists-meta-python.inc
index 20ca2763c..ce5ccf22d 100644
--- a/meta-python/conf/include/ptest-packagelists-meta-python.inc
+++ b/meta-python/conf/include/ptest-packagelists-meta-python.inc
@@ -80,6 +80,7 @@  PTESTS_SLOW_META_PYTHON = "\
     python3-arrow \
     python3-lz4 \
     python3-marshmallow \
+    python3-pytest-localserver \
     python3-traitlets \
     python3-yappi \
 "
diff --git a/meta-python/recipes-devtools/python/python3-pytest-localserver/run-ptest b/meta-python/recipes-devtools/python/python3-pytest-localserver/run-ptest
new file mode 100644
index 000000000..8d2017d39
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-localserver/run-ptest
@@ -0,0 +1,3 @@ 
+#!/bin/sh
+
+pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-pytest-localserver_0.8.1.bb b/meta-python/recipes-devtools/python/python3-pytest-localserver_0.8.1.bb
new file mode 100644
index 000000000..669817829
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-localserver_0.8.1.bb
@@ -0,0 +1,29 @@ 
+SUMMARY = "pytest plugin to test server connections locally."
+HOMEPAGE = "https://github.com/pytest-dev/pytest-localserver"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b8da7a541d738b054dcbf70c31530432"
+
+DEPENDS += "python3-setuptools-scm-native"
+
+inherit pypi python_setuptools_build_meta ptest
+
+SRC_URI[sha256sum] = "66569c34fef31a5750b16effd1cd1288a7a90b59155d005e7f916accd3dee4f1"
+
+SRC_URI += " \
+        file://run-ptest \
+"
+
+RDEPENDS:${PN}-ptest += " \
+	python3-pytest \
+	python3-requests \
+	python3-unittest-automake-output \
+"
+
+do_install_ptest() {
+        install -d ${D}${PTEST_PATH}/tests
+        cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
+
+RDEPENDS:${PN} += " \
+	python3-werkzeug \
+"