diff mbox series

[meta-python] python3-sqlalchemy: upgrade 2.0.25 -> 2.0.26

Message ID 20240213064709.102285-1-alperyasinak1@gmail.com
State Under Review
Headers show
Series [meta-python] python3-sqlalchemy: upgrade 2.0.25 -> 2.0.26 | expand

Commit Message

Alper Ak Feb. 13, 2024, 6:47 a.m. UTC
Upstream provides a pyproject.toml which declares the "python_setuptools_build_meta" backend for PEP-517 packaging and requires cython

Changelog:

https://docs.sqlalchemy.org/en/20/changelog/changelog_20.html#change-2.0.26

Signed-off-by: alperak <alperyasinak1@gmail.com>
---
 .../python/python3-sqlalchemy_2.0.25.bb       | 25 ------------------
 .../python/python3-sqlalchemy_2.0.26.bb       | 26 +++++++++++++++++++
 2 files changed, 26 insertions(+), 25 deletions(-)
 delete mode 100644 meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.25.bb
 create mode 100644 meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.26.bb

Comments

Yoann Congal Feb. 13, 2024, 8:39 a.m. UTC | #1
Hi,

Le 13/02/2024 à 07:47, Alper Ak a écrit :
> Upstream provides a pyproject.toml which declares the "python_setuptools_build_meta" backend for PEP-517 packaging and requires cython
> 
> Changelog:
> 
> https://docs.sqlalchemy.org/en/20/changelog/changelog_20.html#change-2.0.26
> 
> Signed-off-by: alperak <alperyasinak1@gmail.com>
> ---
>  .../python/python3-sqlalchemy_2.0.25.bb       | 25 ------------------
>  .../python/python3-sqlalchemy_2.0.26.bb       | 26 +++++++++++++++++++
>  2 files changed, 26 insertions(+), 25 deletions(-)
>  delete mode 100644 meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.25.bb
>  create mode 100644 meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.26.bb

FYI, you can tweak -M argument of git-format-patch to push it to see the rename instead of the deletion/creation (in this case, -M10 does show the rename)

> diff --git a/meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.25.bb b/meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.25.bb
> deleted file mode 100644
> index 35011553c..000000000
> --- a/meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.25.bb
> +++ /dev/null
> @@ -1,25 +0,0 @@
> -DESCRIPTION = "Python SQL toolkit and Object Relational Mapper that gives \
> -application developers the full power and flexibility of SQL"
> -HOMEPAGE = "http://www.sqlalchemy.org/"
> -LICENSE = "MIT"
> -LIC_FILES_CHKSUM = "file://LICENSE;md5=c78b979ae6c20775a28a287d32092cbb"
> -
> -SRC_URI[sha256sum] = "a2c69a7664fb2d54b8682dd774c3b54f67f84fa123cf84dda2a5f40dcaa04e08"
> -
> -PYPI_PACKAGE = "SQLAlchemy"
> -inherit pypi setuptools3
> -
> -RDEPENDS:${PN} += " \
> -    python3-asyncio \
> -    python3-compression \
> -    python3-json \
> -    python3-logging \
> -    python3-netclient \
> -    python3-numbers \
> -    python3-pickle \
> -    python3-profile \
> -    python3-threading \
> -    python3-typing-extensions \
> -"
> -
> -BBCLASSEXTEND = "native nativesdk"
> diff --git a/meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.26.bb b/meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.26.bb
> new file mode 100644
> index 000000000..4aaaa1f22
> --- /dev/null
> +++ b/meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.26.bb
> @@ -0,0 +1,26 @@
> +DESCRIPTION = "Python SQL toolkit and Object Relational Mapper that gives \
> +application developers the full power and flexibility of SQL"
> +HOMEPAGE = "http://www.sqlalchemy.org/"
> +LICENSE = "MIT"
> +LIC_FILES_CHKSUM = "file://LICENSE;md5=c78b979ae6c20775a28a287d32092cbb"
> +
> +SRC_URI[sha256sum] = "e1bcd8fcb30305e27355d553608c2c229d3e589fb7ff406da7d7e5d50fa14d0d"
> +
> +PYPI_PACKAGE = "SQLAlchemy"
> +
> +inherit pypi python_setuptools_build_meta
> +
> +DEPENDS = "${PYTHON_PN}-cython-native"
> +
> +RDEPENDS:${PN} += " \
> +    ${PYTHON_PN}-typing-extensions \
> +    ${PYTHON_PN}-greenlet \
> +    ${PYTHON_PN}-netclient \
> +    ${PYTHON_PN}-profile \
> +    ${PYTHON_PN}-compression \
> +    ${PYTHON_PN}-asyncio \
> +    ${PYTHON_PN}-json \
> +    ${PYTHON_PN}-sqlite3 \

Maybe keep this list sorted?

Also, I wonder if the ${PYTHON_PN}-xxx pattern is still useful (IIUC, it was used to handle python2/3 compatibility) ?

> +"
> +
> +BBCLASSEXTEND = "native nativesdk"

Neither nativesdk-python3-sqlalchemy nor python3-sqlalchemy-native can be built:
ERROR: Nothing RPROVIDES 'python3-greenlet-native' (but virtual:native:/home/yocon/Documents/projets/yocto/poky/meta-openembedded/meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.26.bb RDEPENDS on or otherwise requires it)
NOTE: Runtime target 'python3-greenlet-native' is unbuildable, removing...
Missing or unbuildable dependency chain was: ['python3-greenlet-native']
ERROR: Nothing RPROVIDES 'nativesdk-python3-greenlet' (but virtual:nativesdk:/home/yocon/Documents/projets/yocto/poky/meta-openembedded/meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.26.bb RDEPENDS on or otherwise requires it)
NOTE: Runtime target 'nativesdk-python3-greenlet' is unbuildable, removing...
Missing or unbuildable dependency chain was: ['nativesdk-python3-greenlet']
NOTE: Runtime target 'nativesdk-python3-sqlalchemy' is unbuildable, removing...
Missing or unbuildable dependency chain was: ['nativesdk-python3-sqlalchemy', 'nativesdk-python3-greenlet']
NOTE: Runtime target 'nativesdk-python3-sqlalchemy-dev' is unbuildable, removing...
Missing or unbuildable dependency chain was: ['nativesdk-python3-sqlalchemy-dev', 'nativesdk-python3-greenlet']


Regards,
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.25.bb b/meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.25.bb
deleted file mode 100644
index 35011553c..000000000
--- a/meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.25.bb
+++ /dev/null
@@ -1,25 +0,0 @@ 
-DESCRIPTION = "Python SQL toolkit and Object Relational Mapper that gives \
-application developers the full power and flexibility of SQL"
-HOMEPAGE = "http://www.sqlalchemy.org/"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=c78b979ae6c20775a28a287d32092cbb"
-
-SRC_URI[sha256sum] = "a2c69a7664fb2d54b8682dd774c3b54f67f84fa123cf84dda2a5f40dcaa04e08"
-
-PYPI_PACKAGE = "SQLAlchemy"
-inherit pypi setuptools3
-
-RDEPENDS:${PN} += " \
-    python3-asyncio \
-    python3-compression \
-    python3-json \
-    python3-logging \
-    python3-netclient \
-    python3-numbers \
-    python3-pickle \
-    python3-profile \
-    python3-threading \
-    python3-typing-extensions \
-"
-
-BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.26.bb b/meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.26.bb
new file mode 100644
index 000000000..4aaaa1f22
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-sqlalchemy_2.0.26.bb
@@ -0,0 +1,26 @@ 
+DESCRIPTION = "Python SQL toolkit and Object Relational Mapper that gives \
+application developers the full power and flexibility of SQL"
+HOMEPAGE = "http://www.sqlalchemy.org/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c78b979ae6c20775a28a287d32092cbb"
+
+SRC_URI[sha256sum] = "e1bcd8fcb30305e27355d553608c2c229d3e589fb7ff406da7d7e5d50fa14d0d"
+
+PYPI_PACKAGE = "SQLAlchemy"
+
+inherit pypi python_setuptools_build_meta
+
+DEPENDS = "${PYTHON_PN}-cython-native"
+
+RDEPENDS:${PN} += " \
+    ${PYTHON_PN}-typing-extensions \
+    ${PYTHON_PN}-greenlet \
+    ${PYTHON_PN}-netclient \
+    ${PYTHON_PN}-profile \
+    ${PYTHON_PN}-compression \
+    ${PYTHON_PN}-asyncio \
+    ${PYTHON_PN}-json \
+    ${PYTHON_PN}-sqlite3 \
+"
+
+BBCLASSEXTEND = "native nativesdk"