diff mbox series

[meta-networking] radvd: Fix build in reproducible test

Message ID 20240208111348.344696-1-yoann.congal@smile.fr
State Accepted
Headers show
Series [meta-networking] radvd: Fix build in reproducible test | expand

Commit Message

Yoann Congal Feb. 8, 2024, 11:13 a.m. UTC
In reproducible test, useradd config comes from static files:
  meta-networking/files/static-{passwd,group}-meta-networking

Those files were not coherent :
* an unused "rasvd" was defined (a typo for "radvd")
* passwd referenced a unexisting group id.

This patch aligns static files to the USERADD_PARAM recipe value.

This will fix the errors seen during reproducibility tests:
stdio: ERROR: radvd-2.19-r0 do_prepare_recipe_sysroot: radvd: useradd command did not succeed.
stdio: ERROR: radvd-2.19-r0 do_prepare_recipe_sysroot: ExecutionError('/home/pokybuild/yocto-worker/reproducible-meta-oe/build/build/build-st-meta-networking/build-st/reproducibleA/tmp/work/core2-64-poky-linux/radvd/2.19/temp/run.useradd_sysroot.1178426', 1, None, None)
stdio: ERROR: Logfile of failure stored in: /home/pokybuild/yocto-worker/reproducible-meta-oe/build/build/build-st-meta-networking/build-st/reproducibleA/tmp/work/core2-64-poky-linux/radvd/2.19/temp/log.do_prepare_recipe_sysroot.1178426
stdio: ERROR: Task (/home/pokybuild/yocto-worker/reproducible-meta-oe/build/meta-openembedded/meta-networking/recipes-daemons/radvd/radvd_2.19.bb:do_prepare_recipe_sysroot) failed with exit code '1'

Signed-off-by: Yoann Congal <yoann.congal@smile.fr>
---
 meta-networking/files/static-group-meta-networking  | 1 -
 meta-networking/files/static-passwd-meta-networking | 2 +-
 2 files changed, 1 insertion(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/meta-networking/files/static-group-meta-networking b/meta-networking/files/static-group-meta-networking
index 6896a181e..1b6de8d1c 100644
--- a/meta-networking/files/static-group-meta-networking
+++ b/meta-networking/files/static-group-meta-networking
@@ -4,7 +4,6 @@  dovenull:x:632:
 postfix:x:633:
 postdrop:x:634:
 vmail:x:635:
-rasvd:x:636:
 frr:x:637:
 frrvty:x:638:
 nogroup:x:65534:
diff --git a/meta-networking/files/static-passwd-meta-networking b/meta-networking/files/static-passwd-meta-networking
index 77c2b36f9..03dc2133c 100644
--- a/meta-networking/files/static-passwd-meta-networking
+++ b/meta-networking/files/static-passwd-meta-networking
@@ -3,7 +3,7 @@  dovecot:x:631:631::/:/bin/nologin
 dovenull:x:632:632::/:/bin/nologin
 postfix:x:633:633::/:/bin/nologin
 vmail:x:635:635::/:/bin/nologin
-radvd:x:636:636::/:/bin/nologin
+radvd:x:636:nogroup::${localstatedir}/run/radvd/:/bin/nologin
 frr:x:637:637::/:/bin/nologin
 ftp:x:640:640::/:/bin/nologin
 rwhod:x:641:641::/:/bin/nologin