diff mbox series

[meta-python] python3-gspread: upgrade 6.0.0 -> 6.0.1

Message ID 20240208055812.44945-1-alperyasinak1@gmail.com
State Accepted
Headers show
Series [meta-python] python3-gspread: upgrade 6.0.0 -> 6.0.1 | expand

Commit Message

Alper Ak Feb. 8, 2024, 5:58 a.m. UTC
Upstream provides a pyproject.toml which declares a flit_core.buildapi build backend for PEP-517 packaging

Changelog:

Allow client to use external Session object
Remove-py-3.7-support
bugfix/client export
Fix oauth flow typo
check oauth creds type using isinstance
Fix type hints at find method in worksheet.py
Fixup get empty cell value is None
Fix missing attribute spreadsheet in Worksheet
update migration guide

Signed-off-by: alperak <alperyasinak1@gmail.com>
---
 .../python3-gspread/python3-gspread_6.0.0.bb       | 12 ------------
 .../python3-gspread/python3-gspread_6.0.1.bb       | 14 ++++++++++++++
 2 files changed, 14 insertions(+), 12 deletions(-)
 delete mode 100644 meta-python/recipes-devtools/python3-gspread/python3-gspread_6.0.0.bb
 create mode 100644 meta-python/recipes-devtools/python3-gspread/python3-gspread_6.0.1.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python3-gspread/python3-gspread_6.0.0.bb b/meta-python/recipes-devtools/python3-gspread/python3-gspread_6.0.0.bb
deleted file mode 100644
index c04b1568b..000000000
--- a/meta-python/recipes-devtools/python3-gspread/python3-gspread_6.0.0.bb
+++ /dev/null
@@ -1,12 +0,0 @@ 
-SUMMARY = "Google Spreadsheets Python API"
-HOMEPAGE = "https://github.com/burnash/gspread"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=9488e21983675fa56dc05af558b83e2f"
-
-SRC_URI[sha256sum] = "3b5efe315aeaa290d21befc8ee7bb0239db78c7b495d8831ae29fd1a182292a1"
-
-S = "${WORKDIR}/gspread-${PV}"
-
-RDEPENDS:${PN} = "python3-requests"
-
-inherit pypi python_poetry_core
diff --git a/meta-python/recipes-devtools/python3-gspread/python3-gspread_6.0.1.bb b/meta-python/recipes-devtools/python3-gspread/python3-gspread_6.0.1.bb
new file mode 100644
index 000000000..7854b7562
--- /dev/null
+++ b/meta-python/recipes-devtools/python3-gspread/python3-gspread_6.0.1.bb
@@ -0,0 +1,14 @@ 
+SUMMARY = "Google Spreadsheets Python API"
+HOMEPAGE = "https://github.com/burnash/gspread"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=9488e21983675fa56dc05af558b83e2f"
+
+SRC_URI[sha256sum] = "8c8bf83be676a019d3a483455d8b17b442f2acfc620172f245422ca4fc960dd0"
+
+RDEPENDS:${PN} = " \
+	${PYTHON_PN}-google-auth \
+	${PYTHON_PN}-google-auth-oauthlib \
+	${PYTHON_PN}-strenum \
+	"
+
+inherit pypi python_flit_core