diff mbox series

[meta-python] python3-pychromecast: add missing RDEPENDS, and add initial recipe for dependency.

Message ID 20240204113929.2629588-1-t.f.g.geelen@gmail.com
State Accepted
Headers show
Series [meta-python] python3-pychromecast: add missing RDEPENDS, and add initial recipe for dependency. | expand

Commit Message

Tom Geelen Feb. 4, 2024, 11:39 a.m. UTC
python3-pychromecast mentions casttube as a runtime dependency. Included is an initial
recipe as well.
Signed-off-by: Tom Geelen <t.f.g.geelen@gmail.com>
---
 .../python/python3-casttube_0.2.0.bb                | 13 +++++++++++++
 .../python/python3-pychromecast_13.1.0.bb           |  1 +
 2 files changed, 14 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-casttube_0.2.0.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-casttube_0.2.0.bb b/meta-python/recipes-devtools/python/python3-casttube_0.2.0.bb
new file mode 100644
index 000000000..408dff87b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-casttube_0.2.0.bb
@@ -0,0 +1,13 @@ 
+SUMMARY = "YouTube Chromecast API"
+HOMEPAGE = "https://github.com/ur1katz/casttube"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=8227180126797a0148f94f483f3e1489"
+
+SRC_URI[md5sum] = "4bb24ba1639d16c8fa367537bf3b88a6"
+SRC_URI[sha256sum] = "f25b3c634efe702896233690f7590e8d6311590910f18dbb763b90419d9ef53c"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} = "\
+    ${PYTHON_PN}-requests \
+"
diff --git a/meta-python/recipes-devtools/python/python3-pychromecast_13.1.0.bb b/meta-python/recipes-devtools/python/python3-pychromecast_13.1.0.bb
index feae3174a..618aba4a6 100644
--- a/meta-python/recipes-devtools/python/python3-pychromecast_13.1.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pychromecast_13.1.0.bb
@@ -16,4 +16,5 @@  RDEPENDS:${PN} += " \
     ${PYTHON_PN}-requests \
     ${PYTHON_PN}-protobuf \
     ${PYTHON_PN}-compression \
+    ${PYTHON_PN}-casttube \
 "